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CREATING GRAPHICS 
AND TEXT 

 
Lesson Overview 

In this lesson, you’ll learn how to do the following: 

• Draw rectangles, ovals, and other shapes 

• Modify the shape, color, and size of drawn objects 

• Understand fill and stroke settings 

• Create and edit curves and variable-width strokes 

• Use Art and Pattern brushes for expressive drawing 

• Edit colors quickly with tagged swatches 

• Apply gradients and transparencies 

• Create and edit text 

• Add web fonts into HTML5 Canvas documents 

• Distribute objects on the Stage 

• Export art to SVG 

This lesson will take about two hours to complete. Please log in to your 
account on peachpit.com to download the lesson files for this chapter, or 
go to the Getting Started section at the beginning of this book and follow 
the instructions under “Accessing the Lesson Files and Web Edition.” 
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You can use rectangles, ovals, lines, and custom art or 
pattern brushes to create interesting, complex graph- 
ics and illustrations in Adobe Animate CC . Edit their 
shapes and combine them with gradients, transpar- 
encies, text, and filters for even greater expressive 
possibilities . 

 

37 



From the Library of Alvaro Alvarez  

● Note If you have not 
already downloaded 
the project files for 
this lesson to your 
computer from your 
Account page, make 
sure to do so now . See 
Getting Started at the 
beginning of the book . 

Getting Started 
Start by viewing the finished movie to see the project you’ll be creating in this 
lesson. 

1 Double-click the 02End.html file in the Lesson02/02End folder to view the final 
project in a browser. 

 
 

The project is a simple static illustration for a banner ad. This illustration is for 
Mug’s Coffee, a fictional cafe that’s promoting its store and coffee. In this lesson, 
you’ll draw the shapes, modify them, and learn to combine simple elements to 
create more complex visuals. You won’t create any animation just yet. After all, 
you must learn to walk before you can run! And learning to create and modify 
graphics is an important step before doing any animation with Animate. 

2 In Animate, choose File > New. In the New Document dialog box, choose 
HTML5 Canvas. 

3 On the right-hand side of the dialog box, make the Stage size 700 pixels by 200 
pixels, and make the color of the Stage a light brown by clicking the icon next to 
Background Color and then clicking the #CC9966 color swatch. Click OK. 

4 Choose File > Save. Name the file 02_workingcopy.fla and save it in the 02Start 
folder. Saving your file right away is a good working habit (even if you’ve enabled 
the Auto-Recovery feature). It ensures that you won’t lose your work if the 
application or your computer crashes. 

 
Understanding Strokes and Fills 
Every graphic in Animate starts with a shape. A shape consists of two components: 
the fill, or the insides of the shape, and the stroke, or the outlines of the shape. If you 
always keep these two components in mind, you’ll be well on your way to creating 
beautiful and complicated visuals. 

The fill and the stroke function independently of each other, so you can modify or 
delete either without affecting the other. For example, you can create a rectangle 
with a blue fill and a red stroke, and then later change the fill to purple and delete 
the red stroke entirely. You’ll be left with a purple rectangle without an outline. You 
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can also move the fill or stroke independently, so if you want to move the entire 
shape, make sure that you select both its fill and stroke. 

 

Creating Shapes 
Animate includes several drawing tools, which work in different drawing modes. 
Many of your creations will begin with simple shapes such as rectangles and ovals, 
so it’s important that you’re comfortable drawing them, modifying their appearance, 
and applying fills and strokes. 

You’ll begin by drawing the cup of coffee. 
 
Using the Rectangle tool 
The coffee cup is essentially a cylinder, which is a rectangle with an oval at the top and 
an oval at the bottom. You’ll start by drawing the rectangular body. It’s useful to break 
down complicated objects into their component parts to make drawing them easier. 

1 In the Tools panel, select the Rectangle tool ). Make sure the Object Drawing 
mode icon ( ) is not selected. 

2 Choose a stroke color ) and a fill color ) from the bottom 
of the Tools panel. Choose #663300 (dark brown) for the stroke 
and #CC6600 (light brown) for the fill. 

3 On the Stage, draw a rectangle that is a little taller than 
it is wide. You’ll specify the exact size and position of the 
rectangle in step 6. 

4 Select the Selection tool ). 

5 Drag the Selection tool around the entire rectangle to 
select its stroke and its fill. When a shape is selected, 
Animate displays it with white dots. You can also double- 
click a shape, and Animate will select both the stroke and 
fill of the shape. 

6 In the Properties panel, Position And Size section, enter 130 for the width   and 
150 for the height. Press Enter (Windows) or Return (Mac) to apply the values. 

Using the Oval tool 
Now you’ll create the opening at the top and the rounded bottom. 

1 In the Tools panel, select the Oval tool. 

2 Make sure the Snap To Objects button ) is selected. This option forces 
shapes that you draw on the Stage to snap to each other to ensure that lines and 
corners connect to one another. 

● Note In Animate 
CC, as well as in 
HTML documents 
and in web design 
and development in 
general, colors are 
often specified by 
hexadecimal numbers . 
The six digits after the 
# sign represent the 
red, green, and blue 
contributions to the 
color . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Note Even though 
we have set the color  
of the Stage to brown, 
many figures in this 
chapter are set on a 
white background to 
enhance the visibility of 
the tool or technique 
being described . 
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3 Drag from one side of the rectangle to the other to make an 
oval that touches both sides. Snap to Objects makes the sides 
of the oval connect to the sides of the rectangle. 

 
 
● Note The last fill 
and stroke you used 
are applied to the next 
objects you create, 
unless you change 
the settings before 
you draw . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Tip If you press 
the Option or Alt key 
while moving one of 
the control points, 
Animate scales the 
selected object relative 
to its transformation 
point, represented 
by the circle icon . 
You can move the 
transformation point 
anywhere, even outside 
the object . Press Shift 
to constrain the object 
proportions . Hold Ctrl/ 
Command to distort 
the object from a single 
control point . 

4 Draw another oval near the bottom of the rectangle. 
 
 
 
Making Selections 
To modify an object, you must first be able to select different parts of it. In Animate, 
you can make selections using the Selection, Subselection, or Lasso tool. Typically, 
you use the Selection tool to select an entire object or a section of an object. The 
Subselection tool lets you select a specific point or line in an object. With the Lasso 
tool, you can make a free-form selection. 

Selecting strokes and fills 
Now you’ll make the rectangle and ovals look more like a coffee cup. 
You’ll use the Selection tool to delete unwanted strokes and fills. 

1 In the Tools panel, select the Selection tool ). 

2 Click the fill above the top oval to select it. 

The shape above the top oval is highlighted. 

3 Press the Backspace (Windows)/Delete (Mac) key. 

The fill is cleared from the selected area. 

4 Shift-click each of the three line segments above the top oval to 
select them all and press Backspace/Delete. 

Animate deletes the individual strokes, leaving the top oval 
connected to the rectangle. 

5 Now Shift-select the fill and strokes below the bottom oval, as 
well the oval’s upper arc (which represents the inside of the 
bottom of the cup), and press Backspace/Delete. 

The remaining shape appears as a cylinder. 
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Editing Shapes 
When drawing in Animate, you’ll often start with the Rectangle and Oval tools. But 
to create more complex graphics, you’ll use other tools to modify those base shapes. 
The Free Transform tool, the Copy and Paste commands, and the Selection tool can 
help transform the plain cylinder into a coffee cup. 

Using the Free Transform tool 
The coffee cup will look more realistic if you taper the bottom rim. You’ll use the 
Free Transform tool to change its overall shape. With the Free Transform tool, you 
can change an object’s scale, rotation, or skew (the way it is slanted), or distort an 
object by dragging control points around a bounding box. 

1 In the Tools panel, select the Free Transform tool ). 

2 Drag the Free Transform tool around the cylinder on the 
Stage to select it. 

Transformation handles appear on the cylinder. 

3 Press and hold Shift+Ctrl/Shift+Command as you drag one of 
the lower corners inward. Holding these keys while dragging 
lets you move both corners the same distance simultaneously. 

4 Click outside the shape to deselect it. 

The bottom of the cylinder is narrow, and the top is wide. It 
now looks more like a coffee cup. 

Using Copy and Paste 
Use Copy and Paste commands to easily duplicate shapes on the Stage. You’ll set the 
surface level of the coffee by copying and pasting the top rim of the coffee cup. 

1 Select the Selection tool. Hold down the Shift key and select the 
top arc and bottom arc of the coffee cup opening. 

2 Choose Edit > Copy (Ctrl+C/Command+C). The top strokes of 
the oval are copied. 

3 Choose Edit > Paste In Place (Shift+Ctrl+V/ 
Shift+Command+V). 

A duplicate oval appears on the Stage, exactly overlying the original that you 
copied. The duplicate remains selected. 

4 In the Tools panel, select the Free Transform tool. 

Transformation handles appear on the oval. 
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5 Press the Shift key as you drag a corner inward. Make the oval 
about 10 percent smaller. Pressing the Shift key lets you change 
the shape uniformly so the oval maintains its aspect ratio. 

The top edge of the coffee cup is in place. 

6 Choose Edit > Paste In Place (Shift+Ctrl+V/ 
Shift+Command+V) one more time to add another 
duplicate of the original oval to the Stage. 

7 Select the Free Transform tool. Shift-drag a corner 
inward to shrink the new oval about another 10 
percent smaller. 

8 Drag the oval over the rim of the coffee cup so it 
overlaps the front lip. You can also press the Down 
Arrow key to nudge the selected oval down the Stage. 

9 Click outside the selection to deselect the oval. 

10 Select the lower portions of the smaller oval and 
delete them. 

Your coffee cup now is filled with coffee! 
 

Changing shape contours 
With the Selection tool, you can push and pull lines and corners to change the over- 
all contours of any shape. It’s a fast and intuitive way of working with shapes. 

1 In the Tools panel, select the Selection tool. 

2 Move your mouse cursor close to one of the sides of the coffee cup. 

A curved line appears near your cursor, indicating that you can change the 
curvature of the stroke. 

3 Drag the stroke outward. 

The side of the coffee cup bends, giving the cup a slight bulge. 
 
 
 
 
 
 
 
 

� Tip Hold down the 
Option/Alt key while 
dragging the sides of 
a shape to add a new 
corner . 

 

4 Drag the other side of the coffee cup outward slightly. 

The coffee cup now has a more rounded body. 
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Changing strokes and fills 
If you want to change the properties of any stroke or fill, you can use the Ink Bottle 
tool or the Paint Bucket tool. The Ink Bottle tool changes stroke colors; the Paint 
Bucket tool changes fill colors. 

1 In the Tools panel, select the Paint Bucket tool ). 

2 In the Properties panel, choose a darker brown Fill color (#663333). 
 
 
 
 
 
 
 
 
 
 
 
 
 

3 Click the top surface of the coffee that is inside the cup. 

The fill of the top oval changes to the darker brown color. 
 

 

4 In the Tools panel, select the Ink Bottle tool ). 

5 In the Properties panel, choose a darker brown stroke color (#330000). 

6 Click the top stroke above the surface of the coffee. 

The stroke around the surface of the coffee changes to a darker brown color. 

� Tip If your Paint 
Bucket tool changes the 
fill in surrounding areas, 
there may be a small 
gap in the shape outline 
that allows the fill to 
spill over . Close the gap 
manually, or use the 
Gap Size menu at the 
bottom of the Tools 
panel to choose the gap 
size that Animate will 
close automatically . 

 

 
� Tip You can also 
select a stroke or a fill 
and change its color by 
using the Properties 
panel without selecting 
the Paint Bucket or Ink 
Bottle tool . 
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44  LESSON 2    Creating Graphics and  Text 

Animate drawing modes 
Animate provides three drawing modes that determine how objects interact 
with one another on the Stage and how you can edit them . By default, Animate 
uses Merge Drawing mode, but you can enable Object Drawing mode or use the 
Rectangle Primitive or Oval Primitive tool to use Primitive Drawing mode . 

Merge Drawing mode 

In this mode, Animate merges drawn shapes, such as rectangles and ovals, where 
they overlap, so that multiple shapes appear to be a single shape . If you move or 
delete a shape that has been merged with another, the overlapping portion is 
permanently removed . 

 
 
 
 
 
 
 

Object Drawing mode 

In this mode, Animate does not merge drawn objects; they remain distinct and separate, 
even when they overlap . To enable Object Drawing mode, select the drawing tool you 
want to use, and then click the Object Drawing button at the bottom of the Tools panel . 

To convert an object to shapes (Merge Drawing mode), select it and choose 
Modify > Break Apart (Ctrl+B/Command+B) . To convert a shape to an object (Object 
Drawing mode), select it and choose Modify > Combine Objects > Union . 

 
 
 
 
 
 
 

Primitive Drawing mode 

When you use the Rectangle Primitive tool or the Oval Primitive tool, Animate 
draws your rectangles or ovals as independent objects that maintain some editable 
features . Unlike regular objects, you can modify the corner radius and start and end 
angle of rectangle primitives, and adjust the inner radius of oval primitives using the 
Properties panel . 
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Using Gradient and Bitmap Fills 
The fill is the interior of the drawn object. Currently, you have selected a solid 
brown fill color, but you can also use a gradient or a bitmap image (such as a JPEG 
file) as a fill, or you can specify that the object has no fill at all. 

In a gradient, one color gradually changes into another. Animate can create linear 
gradients, which change color horizontally, vertically, or diagonally, or radial gradi- 
ents, which change color moving outward from a central focal point. 

For this lesson, you’ll use a linear gradient fill to add three-dimensionality to the 
coffee cup. To give the appearance of a top layer of foaming cream, you’ll import a 
bitmap image to use as the fill. You can use the Color panel to import a bitmap file. 

Creating gradient transitions 
You’ll use the Color panel to define the colors to use in your gradient. By default, 
a linear gradient moves from one color to a second color, but you can use up to 
15 color transitions in a gradient in Animate. A color pointer determines where each 
color is defined, and smooth color changes happen between each of the pointers. 
Add color pointers beneath the gradient definition bar in the Color panel to add 
more colors, and hence, more gradients. 

You’ll create a gradient that moves from tan to white to dark tan on the surface of 
the coffee cup to give it a rounded appearance. 

1 Select the Selection tool. Select the fill that 
represents the front surface of the coffee cup. 

2 Open the Color panel (Window > Color). In the 
Color panel, select Fill Color (the Paint Bucket 
icon) and choose Linear Gradient from the Color 
Type menu. 

 

 
The front surface of the coffee cup is filled with a 
color gradient that changes from left to right. 
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3 In the Color panel, select the color pointer at the left end of the color gradient 
definition bar (the triangle above it turns black when selected), and then type 
FFCCCC in the Hex value field to specify a light tan color. Press Enter/Return to 
apply the color. You can also select a color from the color picker or double-click 
the color pointer to select a color from the color swatches. 

4 Select the far-right color pointer, and then enter B86241 for a dark tan color. 
Press Enter/Return to apply the color. 

 

 

The gradient fill for the coffee cup gradually changes from light tan to dark tan 
across its surface. 

5 Click beneath the gradient definition bar to create a new color pointer. 
 

 

6 Drag the new color pointer to the middle of the gradient. 

7 Select the new color pointer, and then type FFFFFF in the Hex value field to 
specify white for the new color. Press Enter/Return to apply the color. 

 

 
� Tip  If the Lock 
Fill button isn’t visible 
on your Tools panel, 
widen the panel by 
dragging the left 
edge (as explained in 
Lesson 1) . This allows 
multiple columns of 
tools to be shown . 

 
The gradient fill for the coffee cup gradually 
changes from light tan to white to dark tan. 

8 Deselect the fill on the Stage by clicking 
elsewhere on the Stage. Select the Paint Bucket 
tool and make sure the Lock Fill button ) at 
the bottom of the Tools panel is deselected. 
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The Lock Fill option locks the current gradient 
to the first shape to which it was applied so that 
subsequent shapes extend the gradient. You’ll 
want a new gradient for the back surface of the 
coffee cup, so the Lock Fill option should be 
deselected. 

9 With the Paint Bucket tool, select the back 
surface of the coffee cup. 

Animate applies the gradient to the back 
surface. 

Using the Gradient Transform tool 
In addition to choosing colors and positioning the color pointers for a gradient, you 
can adjust the size, direction, or center of a gradient fill. To squeeze the gradient in 
the front surface and reverse the gradient in the back surface, you’ll use the Gradient 
Transform tool. 

1 Select the Gradient Transform tool. (The Gradient Transform tool is grouped 
with the Free Transform tool.) 

 
 
 
 
 
 
 
 
 

� Tip To delete a 
color pointer from the 
gradient definition bar, 
simply drag it off the bar . 

 

 
 

2 Click the front surface of the coffee cup. Transformation handles appear. 

3 Drag the square handle on the right side of the 
bounding box inward to squeeze the gradient 
tighter. Drag the center circle to move the 
gradient to the left so the white highlight is 
positioned slightly left of center. 

4 Now click the back surface of the coffee cup. 
Transformation handles appear. 

5 Drag the round handle on the corner of the 
bounding box to rotate the gradient 180 degrees 
so the gradient fades from dark tan on the left to 
white to light tan on the right. Narrow the gradient 
and move it to the right slightly, so the highlight 
falls on the right side of the inner surface. 

The coffee cup now looks more realistic because 
the shadows and highlights make it appear that 
the front surface is convex and the back surface 
is concave. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Tip Move the center 
circle to change the 
center of the gradient, 
drag the arrow circle 
to rotate the gradient, 
or drag the arrow in 
the square to stretch or 
compress the gradient . 
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Adding a bitmap fill 
You’ll make this cup of coffee a little fancier by adding a frothy layer of cream. You’ll 
use a JPEG image of foam as a bitmap fill. 

1 Select the top surface of the coffee with the Selection tool. 

2 Choose Window > Color to open the Color panel. 

3 Choose Bitmap Fill from the Color Type menu. 
 

 
 
 
 
 
 
 

� Tip You can also use 
the Gradient Transform 
tool to change the width, 
orientation, size, or 
rotation of a bitmap fill . 

4 In the Import To Library dialog box, navigate to the 
coffeecream.jpg file in the Lesson02/02Start folder. 

5 Select the coffeecream.jpg file and click Open. 

The top surface of the coffee fills with the foam 
image. 

The cup of coffee is complete! Rename the layer 
containing your completed drawing coffee cup. All 
that’s left to do is to add some hot steam. 

 
Grouping objects 
Now that you’re finished creating your cup of coffee, you can make it into a single 
group. A group holds together a collection of shapes and other graphics to preserve 
their integrity. When the elements that compose the coffee cup are grouped, you 
can move them as a unit without worrying that the cup might merge with underly- 
ing shapes. Use groups to organize your drawing. 

1 Select the Selection tool. 

2 Select all the shapes that make up the cup 
of coffee. 
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3 Choose Modify > Group. 

The cup of coffee is now a single group. 
When you select it, a blue outline indicates its 
bounding box. 

4 If you want to change any part of the cup of 
coffee, double-click the group to edit it. 

Notice that all the other elements on the Stage 
dim, and the Edit bar above the Stage displays 
Scene 1 Group. This indicates that you are now 
in a particular group and can edit its contents. 

 

 

5 Click the Scene 1 icon in the Edit bar at the top of the Stage, or double-click an 
empty part of the Stage, and return to the main scene. 

 
Using Variable-Width Strokes 
You can make many different styles of lines for your strokes. In addition to a solid line, 
you can choose dotted, dashed, or ragged, or even customize your own. In addition, 
you can create lines with variable widths and edit the variations with the Width tool. 

In this lesson, you’ll use the Pencil tool to create variable-width lines to represent 
the aroma wafting off the coffee. You’ll also make the aroma slightly transparent. 
Transparency is measured as a percentage and is referred to as alpha. An Alpha 
value of 100% indicates that a color is totally opaque, whereas an Alpha value of 0% 
indicates that a color is totally transparent. 

Adding variable-width lines 
Now you’ll add some whimsical lines above your coffee illustration to give it some 
personality. 

1 On the Timeline, insert a new layer and name it coffee aroma. You’ll draw your 
lines in this layer. 

2 In the toolbar, select the Pencil tool ). Choose Smooth from the Pencil Mode 
menu at the bottom of the Tools panel. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
� Tip To change a 
group back into its 
component shapes, 
choose Modify > 
Ungroup (Shift+Ctrl+G/ 
Shift+Command+G)  . 
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3 In the Properties panel, select a dark brown stroke color at 50% Alpha value. 

4 For Stroke, enter 15 for the stroke size. From the Style menu, choose Solid, and 
from the Width menu, choose the thick and thin profile, Width Profile 2. 

 
 
 
 
 
 
 
 
 
 
 
� Tip Edit variable- 
width lines as you 
would any other stroke . 
Use the Selection or 
Subselection tool to 
bend the curves or 
move the anchor points . 

 
5 Draw a few wavy lines above the coffee. 

Animate renders each line with a thick-and-thin 
width. Although it appears as a complicated shape, 
the entire object is a single selectable stroke. 

Editing the width of lines 
You can finesse where the bulges appear in your lines, and how much of a bulge 
there is. Use the Width tool to make those edits. 

1 In the Tools panel, select the Width tool ). 

2 Move your mouse pointer over one of your variable-width strokes. 

Anchor points appear along the line to show you where the thick and thin 
portions of the line are located. 
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3 Drag the handles at any anchor point to change the width of the line. Exaggerate 
some of the restrictions and bulges. 

 
 
 
 
 
 
 
 
 
 
 
 

4 Drag an anchor point along the stroke to move its location. 

5 Drag anywhere along the stroke to add a new anchor point and 
define the width at that location. Animate displays a small plus 
sign next to your pointer to indicate that you can add an anchor 
point. 

 
Using Swatches and Tagged Swatches 
Swatches are preset samples of color. Access them via the Swatches panel (Window > 
Swatches, or Ctrl+F9/Command+F9). You can also save colors that you’ve used in 
your graphics as new swatches so you always have them to refer to. 

Tagged swatches are specially marked swatches that are linked to the graphics on 
your Stage that are using them. If you change a tagged swatch in your Swatch panel, 
all your graphics that use the tagged swatch will be updated. 

Saving a swatch 
You’ll save a swatch for the brown color that you used for the wisps of coffee steam 
above the mug. 

1 Select the Selection tool and click one of the variable-width strokes above your 
coffee mug. 

 
� Tip Hold down Alt/ 
Option when you want 
to modify only one side 
of a variable-width line . 

� Tip To delete an 
anchor point of a 
variable-width line, 
click to select the 
anchor point, and press 
Backspace/Delete . 
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2 Open the Swatches panel (Ctrl+F9/Command+F9), or click the Swatches icon. 

The Swatches panel opens, showing the default colors with gradients in the 
bottom row. 

 

3 Click Create A New Swatch at the bottom of the Swatches panel. 

A new swatch appears with the exact color and transparency information of the 
coffee wisp that you selected. 

New swatch 

Create A New Swatch 

 
Creating a tagged swatch 
You’ll convert your saved swatch to a tagged swatch and use it for all the coffee 
wisps. 

1 With the coffee steam color swatch selected, click Convert To A Tagged Swatch 
at the bottom of the Swatch panel. 

 

 

The Tagged Color Definition dialog box appears. 
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2     Enter coffee steam in the Name field and click OK. 
 

 

The dialog box closes and a new tagged swatch appears in the Tagged Swatches 
section of the Swatches panel. 

 

Using a tagged swatch 
You’ll use your new tagged swatch for all your coffee wisps above the mug. 

1 Select the Selection tool and, holding down the Shift key, click every coffee wisp 
above the mug. 

 

 

2 Open the Swatches panel. 
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3 Select the coffee steam tagged swatch. 

The selected graphics use the tagged swatch as their color. In the Properties 
panel, a tagged swatch is indicated by the white triangle in the bottom-right 
corner of the color. 

 

Updating tagged swatches 
The real power of tagged swatches is apparent when you have to make updates to your 
project. Suppose the art director or your client doesn’t like the color of the coffee steam 
rising above the mug. Since each wisp uses a tagged swatch, you can simply update the 
color of the tagged swatch and all graphics using that tagged swatch will update. 

1 Open the Swatches panel. 

2 In the Tagged Swatches section of the Swatches panel, double-click the coffee 
steam tagged swatch. 

The Tagged Color Definition dialog box opens with the name and color information. 

3 Change the color to a different shade of brown. The new color appears in the top 
half of the color preview window. Click OK to close the dialog box. 

 
 
 
 
 
 

New color 
Existing color 

 
 
 
 
 
 
 
 

The new color information is saved and all the graphics using the tagged swatch 
update to the new color. 
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Creating Curves 
You’ve used the Selection tool to pull and push on the edges of shapes to intuitively 
make curves. For more precise control, you can use the Pen tool. 

Using the Pen tool 
Now you’ll create a soothing, wavelike background graphic. 

1 Choose Insert > Timeline > Layer, and name the new layer dark brown wave. 

2 Drag the layer to the bottom of the layer stack. 

3 Lock all the other  layers. 
 

 

4 In the Tools panel, select the Pen tool ). 

5 Set the stroke color to a dark brown and Alpha to 100%. Select the Hairline 
option for Style and Uniform thickness for the Width. 

6 Begin your shape by clicking off the left edge of the Stage to establish the first 
anchor point. 

7 Move the mouse pointer over the Stage and press—but don’t release!—the 
mouse button to place the next anchor point. Keep holding the mouse button 
and drag in the directon you want the line to continue. You will drag out a 
direction line from the new anchor point, and when you release the mouse 
button you will have created a smooth curve between the two anchor points. 

To learn more about drawing with the Pen tool, see the sidebar “Creating paths 
with the Pen tool.” 

 

8 Continue to move the mouse to the right across the Stage, pressing and dragging 
out direction lines to build the outline of the wave. Keep going past the right 
edge of the Stage and click once to set a corner point. 

You have drawn the top edge of your wave; now you need to complete the shape 
by drawing the bottom. 

9 Click once below the previous corner point, and then draw a wavy line back to 
the left across the Stage, similar (but not exactly parallel) to the first curved line. 
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Take care not to place your anchor points directly under the anchor points in the 
upper line so the wave has a free-form outline. 

 

10 Continue the lower wavy line past the left edge of the Stage and click below the 
initial anchor point to place another corner  point. 

11 Close your shape by clicking the first anchor point. 
 

 

12 Select the Paint Bucket tool. 

13 Set the Fill color to a dark brown. 

14 Click inside the outline you just created to fill it with color. 

15 Select the Selection tool, and click the outline to select it. Press the Delete key to 
remove the stroke. 

 
 
● Note Don’t worry 
about making all the 
curves perfect . It takes 
practice to get used to 
the Pen tool . You’ll also 
have a chance to refine 
your curves in the next 
part of the lesson . 

 

Editing curves with the Selection and Subselection tools 
Your first try at creating smooth waves probably won’t be very good. Use the 
Selection tool or the Subselection tool to refine your curves. 

1   Select the Selection tool. 
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2 Hover over a line segment and look at the arced line segment that appears near 
your pointer. This indicates that you can edit the curve. If a right-angle segment 
appears near your cursor, this indicates that you can edit the corner point. 

3 Drag the curve to edit its shape. 
 

 

4 In the Tools panel, select the Subselection tool ). 

5 Click the outline of the shape. 

6 Drag the anchor points to new locations or move the handles to refine the overall 
shape. 

 

 
Deleting or adding anchor points 
Use the hidden tools under the Pen tool to delete or add anchor points as needed. 

1 Press and hold on the Pen tool to access the hidden tools under it. 
 

 

2 Select the Delete Anchor Point tool ). 

3 Click an anchor point on the outline of the shape to delete it. 

4 Select the Add Anchor Point tool ). 

5 Click the curve to add an anchor point. 
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Creating paths with the Pen tool 
You can use the Pen tool to create paths that are straight or curved, open or closed . If 
you’re unfamiliar with the Pen tool, it can be confusing to use at first . Understanding 
the elements of a path and how to create those elements with the Pen tool makes 
paths much easier to draw . 

To create a straight path, click the mouse button . The 
first time you click, you set the starting point . Each 
time that you click thereafter, a straight line is drawn 
between the previous point and the current point . To 
draw complex straight-segment paths with the Pen 
tool, simply continue to add points . 

 
To create a curved path, start by pressing the mouse 
button to place an anchor point, then drag to create 
a direction line for that point and release the mouse 
button . Then move the mouse to place the next anchor 
point and drag out another set of direction lines . At the 
end of each direction line is a direction point; the posi- 
tions of direction lines and points determine the size 
and shape of the curved segment . Moving the direction 
lines and points reshapes the curves in a path . 

Smooth curves are connected by anchor points called 
smooth points . Sharply curved paths are connected 
by corner points . When you move a direction line on a 
smooth point, the curved segments on both sides of 
the point adjust simultaneously, but when you move a 
direction line on a corner point, only the curve on the 
same side of the point as the direction line is adjusted . 

Path segments and anchor points can be moved after 
they’re drawn, either individually or as a group . When 
a path contains more than one segment, you can drag 
individual anchor points to adjust individual segments 
of the path, or select all of the anchor points in a path 
to edit the entire path . Use the Subselection tool to 
select and adjust an anchor point, a path segment, or 
an entire path . 

Creating a straight line 
 

 
 

Creating a curved line 

A. Curved line segment 
B. Direction point 
C. Direction line 
D. Selected anchor point 
E. Unselected anchor 
point 

 

Creating a closed path 

Closed paths differ from open paths in the way that you end each one . To end 
an open path, select the Selection tool or press Escape . To create a closed path, 
position the Pen tool pointer over the starting point (a small º will appear by the 
pointer), and click . Closing a path automatically ends the path . After the path closes, 
the Pen tool pointer appears with a small *, indicating that your next click will start 
a new path . 

Excerpted with permission from Adobe Photoshop CC Classroom in a Book . © 2017 Adobe 
Systems Incorporated and its licensors. All rights reserved. 
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Using Transparency to Create Depth 
Next, you’ll create a second wave to overlap the first wave. You’ll make the second 
wave slightly transparent to create a rich, layered effect. You can apply transparency 
to either the stroke or the fill. 

Modifying the Alpha value of a fill 
1 Select the shape in the dark brown wave layer. 

2 Choose Edit > Copy. 

3 Choose Insert > Timeline > Layer, and name the new layer light brown wave. 
 

 

4 Choose Edit > Paste In Place (Ctrl+Shift+V/Command+Shift+V). 

The Paste In Place command puts the copied item in the exact same position 
from where it was copied. 

5 Select the Selection tool and move the pasted shape slightly to the left or to the 
right so the crests of the waves are somewhat offset. 

 

 

6 Select the fill of the shape in the light brown wave layer. 

7 Choose Window > Color to open the Color panel. Set the fill color to a slightly 
different brown hue (#CC6666), and then change the Alpha value to 50%. 
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� Tip You can 
also change the 
transparency of a shape 
from the Properties 
panel by clicking the 
Fill Color icon and 
changing the Alpha 
value in the pop-up 
color picker . 

The color swatch in the Color panel previews your newly selected color. 
Transparency is indicated by the gray grid that you can see through the 
transparent color swatch. 

 

 
 

Adding shadows 
Transparent fills are effective for creating shadows, which can provide a sense of 
depth for your illustration. You’ll add a shadow for your coffee mug and another 
decorative shadow at the bottom of the Stage. 

1 Choose Insert > Timeline > Layer, and name the new layer shadow. 

2 Choose Insert > Timeline > Layer again, and name the second new layer big 
shadow. 

3 Drag the shadow layer and the big shadow layer to the bottom of the layer stack. 
 

 

4 Select the Oval tool. 

5 For the Stroke, select None, and for the Fill, select a dark brown color (#663300) 
with a 15% Alpha value. 

6 In the shadow layer, draw an oval that sits just under the coffee mug. 
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7 In the big shadow layer, draw a much larger oval whose top edge just extends 
over the bottom of the Stage from below. 

The overlapping transparent ovals add a rich, layered appearance to the 
illustration. 

 
 

Being Expressive with the Paint Brush 
Although the Pen tool excels at making precision curves like the waves you created 
in the background, it’s not very good for creating spontaneous, expressive marks. 

For a more painterly approach, use the Paint Brush tool ). The Paint Brush tool 
allows you to make shapes that are more organic and free-form as well as shapes 
with regularly repeating patterns for borders and decorations. And, as with other 
graphics created with Animate, the shapes you create with the Paint Brush tool 
remain fully vector-based. 

Choose from dozens of different brushes, and if you don’t find something you can 
use, you can customize the brushes or even create your own. 

Exploring the Brush Library 
You’ll add a little pizzazz to this banner ad by using the Paint Brush tool for the café 
name and logo. You’ll hand-draw the letters with a brush that simulates rough chalk 
to provide a little more of a rustic atmosphere to the café brand. 

1 In the Timeline, add a new layer on top of your other layers and rename it chalk. 

2 Select the Paint Brush tool. In the Properties panel, choose a nice stroke color 
that will contrast against the reds and oranges in the artwork that you’ve already 
created. In this example, we chose a vibrant yellow. 

3 In the Fill And Stroke section, enter 15 for the stroke size. 

This will give you a good thickness for the café lettering. 
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4 Now, to choose your brush style, click the Brush Library button (to the right of 
the Style menu). 

 

 

The Brush Library panel opens. Animate organizes all the brushes in large 
categories on the left column: Arrows, Artistic, Decorative, Line Art, Pattern 
Brushes, and Vector Pack. 

5 Select a category to see the subcategories, and select a subcategory to view the 
individual brushes. For this task, select Artistic > Chalk Charcoal Pencil and 
double-click the Charcoal – Thick brush. 

 

 

The Charcoal-Thick brush is added to the Style menu, and it becomes the 
currently active brush style. 
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6   Now for the fun. Next to your coffee mug, hand-letter the name of the café, 
Mug’s Coffee. 

 

 

 

The chalk style lettering looks very complex, but it’s controlled by a simple 
vector line. If you select the Selection or the Subselection tool and click one 
of your letters, you can see the stroke inside each letter. Push and pull on the 
stroke, move, or edit it with the Transform tool just like you would any other 
vector shape. 

 
Creating a pattern 
Now it’s time to add a decorative border around your banner ad. 

1 Create a new layer above all your other layers and rename it border. 

2 Select the Line tool. Click the Stroke color swatch in the Properties panel and 
select a muted brown or orange color that would harmonize well with the rest of 
the background graphics. 
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3 In the Properties panel, click the Brush Library button next to Style. 

The Brush Library panel opens. 

4 Select Pattern Brushes > Dashed > Dashed Square 1.3. If you find something 
more appealing, feel free to select it instead. Double-click your choice. 

 

 

The Dashed Square 1.3 brush is added to the Style menu, and it becomes the 
currently active brush style. 

 
 
 
 
 
 
 
 
 
 
� Tip Hold Shift while 
drawing with the Line 
tool to constrain the 
tool to horizontal or 
vertical lines . 

 
 

5 Create a long horizontal line at the top edge of the Stage and another one at the 
bottom of the Stage. 

The dashed regular pattern at the top and bottom of the Stage provides a nice 
contrast to the curves and chalk-style lettering. 
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Editing and creating your own 
Art or Pattern Brush 
You might not find a brush to your liking in the Brush Library, or you may need 
something very specific for your project . In either case, you can edit an existing 
brush or you can create an entirely new one . Pattern brushes repeat a shape over 
the length of a stroke whereas Art brushes stretch the base art over the length of 
the stroke . 

To edit a brush, click the Edit Brush Style button next to the Style menu in the 
Properties panel . 

 
 
 
 
 
 
 

The Paint Brush Options dialog box appears, with multiple controls to refine how 
the brush applies the base shapes . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Art brushes and Pattern brushes have different options . Experiment with different 
spacing, how the shapes repeat or stretch to fit, or how corners and overlaps are 
handled . When you’re satisfied with your new brush, click Add to add your custom- 
ized brush to the Style menu . 
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To create an entirely new brush, first create 
some shapes on the Stage that you want to 
base your brush on . For example, if you want 
to create a train track, create the base art that 
repeats for a Pattern brush . 

Select the artwork on the Stage; then click the 
Create New Paint Brush From Selection button 
in the Properties panel near the Style menu . 

The Paint Brush Options panel appears . 
From the Type menu, you can choose 
either Art Brush or Pattern Brush, and 
then refine the brush options . The 
preview window shows you the results of 
your chosen options . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Enter a name for your new brush and click Add . Your new brush will be added to 
your Style menu and available for you to use . 
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Managing paint brushes 
If you’ve created a new brush or customized an existing one, you can save it to the 
Brush Library. 

1 Click the Manage Paint Brushes button in the Properties panel. 
 

 

The Manage Document Paint Brushes dialog box opens, displaying the current 
paint brushes that you’ve added to the Style menu. It shows you which ones are 
currently in use on the Stage and which ones aren’t. 

 

2 Select the brushes you want to delete or save to your Brush Library. You cannot 
delete a brush that is currently in use. 

3 If you save a brush to your Brush Library, it’ll appear in the Brush Library in the 
category called My Brushes. 
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    Pivot point 
    Angle of rotation 

Pressure-sensitive graphics tablets 
Animate supports input from pressure-sensitive tablets, such as the Wacom graph- 
ics tablets, to control variable-width strokes or the Art or Pattern brushes . Pressing 
harder with the stylus creates fatter strokes, whereas pressing lightly results in 
thinner strokes . You can adjust the tilt or sensitivity percentages in the Paint Brush 
Options dialog box to modify the range of thicknesses in the shapes you create . Try 
drawing with a stylus on a tablet with variable-width strokes enabled for a natural, 
intuitive way of creating vector images . 

 
 

Rotating the Stage for easier drawing 
When you draw on regular paper, it’s often easier to rotate the page to get a better 
angle to draw or to write something . In Animate, you can do the same thing with 
the Stage using the Rotation tool . 

The Rotation tool is grouped under the Hand tool in the Tools panel . 
 
 
 

Select the Rotation tool and click the Stage to specify the pivot point, indicated by 
a crosshair . Once the pivot point has been established, drag the Stage to rotate it to 
your desired angle . 

 
 
 
 
 
 
 
 
 
 
 
 
 

Click the Center Stage button at the top of the Stage to reset the Stage to its normal 
orientation. 
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Creating and Editing Text 
Now let’s add text to complete this illustration. Various options are available for text 
depending on what kind of document you’re working on. For an HTML5 Canvas 
document like the one in this lesson, you can use static text or dynamic text. 

Use static text for simple display text that uses fonts available on your (the design- 
er’s) computer. When you create static text on the Stage and publish to an HTML5 
project, Animate automatically converts fonts into outlines. That means you don’t 
have to worry about your audience having the required fonts to see the text as you 
intended it. The downside is that too much text can bloat your file size. 

Use dynamic text to leverage web fonts available either through Typekit or Google. 
Thousands of high-quality fonts are available to you via Typekit through your 
Creative Cloud subscription, and the fonts are hosted by Typekit and accessible 
directly through the Properties panel within Animate. High-quality open source 
fonts are available through Google Fonts, which are hosted on Google servers. 

In the next task, you’ll create a tag line for the café and some descriptions of its 
products. You’ll choose an appropriate web font and add the text. 

Using the Text tool to add dynamic text 
You’ll create your text with the Text tool. 

1 Select the top layer. 

2 Choose Insert > Timeline > Layer, and name the new layer text. 

3 Select the Text tool ). 

4 Choose Dynamic Text from the Text Type menu in the Properties panel. 
 

 

5 Drag out a text box under the café name starting near the coffee cup and ending 
at the right edge of the Stage. 
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6 Begin typing. Enter Taste the Difference. 
 

 

The text may not fit, or it might not be the size or font that you want. Don’t 
worry—you’ll select a web font for your text box in the next   task. 

7 Exit the Text tool by choosing the Selection tool. 

8 Add three more pieces of smaller text on the Stage in the same layer just below 
your tag line: Coffee, Pastries, and Free Wi-Fi. 

 

 
Adding a web font 
Now you’ll link a web font to your project. Make sure you have an Internet con- 
nection because Animate retrieves the list of available fonts from the web. The 
processes for adding a Typekit font and a Google Font are very similar. In this task, 
you’ll add a Typekit font. 

1 Select the Taste the Difference text and click Add Web Fonts (its icon is a globe) 
in the Properties panel, in the Character section. Choose Typekit from the menu 
that pops up. 
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Animate displays the Typekit Web Fonts opening screen. 
 

 

2    Click Get Started. 

The Add Web Fonts dialog box appears. 
 

 

All the available Typekit fonts are listed. You can scroll through them all with the 
scroll bar on the right. You can also search for specific fonts or use the Sort By or 
Filter button to narrow your search. 
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3 For now, peruse the range of typefaces and pick one that you think would suit 
this banner ad. Click the name of your preferred font under the sample text. 

 

 

More detail about the selected font appears, including the different styles (italic, 
bold, and so on), its classification (serif or sans serif ), and the foundry name. 

4 Click the Select button. 
 

 

The Select button turns blue and the label changes to Selected. 
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5 Click OK. 

The dialog box closes and the selected web font is added to your project. 

6 In the Properties panel, Character section, choose the newly added web font 
from the Family menu. Web fonts are listed at the very top of the menu. 

 

 

Your selected Typekit web font is applied to the text box on the Stage. Choose a 
color that works nicely with the composition. Adjust the font size and/or the line 
spacing (the space between lines) in the Properties panel (line spacing is in the 
Paragraph section) to get all the text to fit comfortably in the space. 

7 Select the other three pieces of text and use the Family menu to apply the same 
web font. 

 

 
Identifying your domain 
After you add your Typekit web font, you must identify the domain where your 
HTML5 project will be hosted. For Google Fonts, you do not need to perform 
these steps. 

1     Choose File > Publish Settings. 

The Publish Settings dialog box appears. 
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2 Click the Web Fonts tab on the far right tab. 

3 In the empty field, enter the URL where your banner ad will be hosted. Include 
the http:// protocol. Since you won’t actually upload this sample project, you can 
make up a domain name or leave it blank. 

 

 

4 Click OK to close the dialog box. 

5 Choose Control > Test to test your project. 

Animate shows you a preview of the ad in your browser. The Test movie output 
that uses web fonts is meant for preview only. Use the File > Publish option to 
generate the final files to upload to your server. 

 
Removing a web font 
If you change your mind, you can easily remove a Typekit web font and choose a 
different one. 

1   Select the text that uses the web font you want to remove. 
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Searching for the right font 
The Add Web Fonts dialog box provides tools that help you find the right font for 
your project quickly and easily . Previews of the upper- and lowercase forms for A, 
B, C, and D are shown for each font family . If you want to see more details, click the 
font name . Sample sentences are displayed in all the different stylistic variants avail- 
able (italic, bold, regular, and so on) . You can use the Sort button to organize the 
fonts, or you can use the Filter button to show only certain kinds of typefaces, such 
as ones that are serif or sans serif, or ones with thick and thin transitions . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Knowing a little about typography is valuable in creating elegant and impactful 
Animate projects . Typography—the study and practice of creating letter forms—is a 
subtle but essential part of design . The shape of each letter and its interaction with 
neighboring letters and the white space around them can drive the overall look and 
feel, as well as the emotion of your project . 

The two major categories of typefaces are serif and sans serif . 

Serif fonts are distinguished by small lines at the ends of strokes that make up a 
letter form . Times New Roman is the best-known example of a serif typeface . Serif 
typefaces are best used for long passages of text because the serifs help readability . 
Sans serif fonts, on the other hand, lack the 
embellishments at the ends of strokes (“sans” 
is French for “without”) . Sans serif typefaces 
are cleaner, starker, and generally perceived 
as more modern . Helvetica is the best- 
known example of a sans serif typeface . Sans 
serif fonts are often used for larger display 
purposes such as headers or titles . 

Other kinds of typefaces include script, which mimic a calligraphic pen, or decora- 
tive, which are more illustrative and very unique . Within each of these categories are 
a myriad of variations, so take time to think, search, and decide which font would 
best suit your project . 
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2 Deselect the font by choosing a different one. 

In this example, the Merriweather font is deselected and the _sans font is selected. 
 

 

3 Click the Add Web Fonts button and choose Typekit to open the Add Typekit 
Web Fonts dialog box. 

4 Click Selected Fonts. 

Animate displays all the fonts, indicated by a blue checkmark, that have been 
selected for your project. 

 

If the font has a gray checkmark, that means you’re still using it in some text 
on the Stage. You must deselect a font from every bit of text before removing it 
from your project. 

5 Deselect the font by clicking on it. 

Now, no fonts are displayed in the Selected Fonts area. 
 

 

6 Click OK. 

The Add Web Fonts dialog box closes. The web font is removed from the Family 
menu in the Properties panel. 
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Matching the color of an existing object 
If you want to match a color exactly, you can use the Eyedropper tool )  to 
sample a fill or a stroke. After you click an object with the Eyedropper tool, Animate 
automatically switches to the Paint Bucket tool or the Ink Bottle tool loaded with 
the selected color and associated properties that you can apply to another object. 

You’ll use the Eyedropper tool to sample the color of one of the decorative back- 
ground waves and apply it to the three pieces of smaller text. 

1 Select the Selection tool. 

2 Shift-select all three of the smaller pieces of text: Coffee, Pastries, and Free 
Wi-Fi. 

 

 

3 Select the Eyedropper tool. 

4 Click the fill of the shape in the dark brown wave layer. 
 

 

The three selected pieces of text change color to match the fill of the dark brown 
wave layer. Using the same colors helps to unify the composition. 

 
 

Aligning and Distributing Objects 
Finally, you’ll tidy up the text so the layout is organized. Although you can use rulers 
(View > Rulers) and grids (View > Grid > Show Grid) to help position objects, here 
you’ll use the Align panel, which is more effective when you’re dealing with multiple 
objects. You’ll also rely on the smart guides that appear when you move objects 
around the Stage. 
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Aligning objects 
The Align panel, as you might guess, aligns any number of selected objects horizon- 
tally or vertically. It can also distribute objects   evenly. 

1 Select the Selection tool. 

2 Select the first small piece of text, Coffee. 

3 Move the text box left or right until smart guides appear. Align the left edge of 
the selected text with the left edge of the larger text above it. 

 

 

4 Select the third small piece of text, Free Wi-Fi. 

5 Move the text left or right until smart guides appear. Align the right edge of the 
selected text with the right edge of the larger text above it. 

 

 

6 Shift-click all three small pieces of text to select them. 

7 Open the Align panel (Window > Align). 
 
 

      Align Bottom Edge 
 
 

      Space Evenly Horizontally 
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8 Deselect the Align to Stage option, if it is already selected. Click the Align 
Bottom Edge button. 

Animate aligns the bottom edges of the text. 

9 Click the Space Evenly Horizontally button. 

The selected text is adjusted so that the spaces between them become uniform. 
 

 

 
 
 
 
 
 
 
� Tip  You might 
have to lock the lower 
layers so you don’t 
accidentally select the 
shapes in the lower 
layers . 

 
 

Converting and Exporting Art 
You’ve completed your composition, made up of a simple illustration and layered 
design and text elements. You may still need to take additional steps, however, in 
order to optimize it for display in the final, published playback environment. 

Converting vector art to bitmap art 
Vector art, especially art with complex curves and many shapes and different line 
styles, can be processor-intensive and can take its toll on mobile devices, where per- 
formance suffers. The Convert To Bitmap command provides a way to turn selected 
artwork on the Stage into a single bitmap, which can be less taxing on the processor. 

Once you’ve converted the object to a bitmap, you can move it without worrying 
about it merging with underlying shapes. However, the graphics are no longer edit- 
able with Animate’s editing tools. 

1 Select the Selection tool. 

2 Unlock your layers. Select the wavy coffee aroma lines in the coffee aroma layer, 
as well as the coffee group in the coffee cup layer. 
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3 Choose Modify > Convert To Bitmap. 

Animate converts the cup of coffee and wavy lines to a single bitmap and stores 
the bitmap in the Library panel. 

 

Choose Edit > Undo (Ctrl+Z/Command+Z) to undo the conversion to bitmap 
and revert your coffee mug and aroma strokes to vector graphics. 

Exporting art as PNG, JPG, or GIF 
If you want a simple image file in a format such as a PNG, JPG, or GIF, use the 
Export Image panel to choose your format and fine-tune the compression for 
optimal web download performance. 

1 Choose File > Export > Export Image. 

The Export Image dialog box  opens. 
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2 Choose the appropriate file format, select the amount of compression, select a 
color palette, and even compare different settings to weigh image quality and file 
size. You can also resize the image. 

That Animate provides such a robust environment for creating compelling, rich, 
and sophisticated graphics and text paired with such flexibility in output options 
is truly remarkable, and something that will help drive all your creative pursuits. 

 
 
● Note If your 
Animate document 
contains multiple 
frames, you can also 
choose to export it as 
an animated GIF . 
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Exporting art as SVG 
Scalable Vector Graphics (SVG) is a common XML-based format for displaying vec- 
tor graphics in a browser . You can export your final composition from Animate as 
SVG, embedding or linking any bitmap images . The exported SVG produces a static 
image of your project . However, SVG only supports static text . 

To export your artwork as SVG, do the following: 

1 Choose File > Export > Export Image (Legacy) . 

2 From the File Format menu, choose SVG Image (* .svg) and click Save . 

3 In the ExportSVG dialog box that appears, select Embed for Image Location . 
 
 
 
 
 
 
 
 
 
 
 

 
The Image Location options determine whether your bitmap images are encoded into 
the SVG file or kept as separate files and linked to your SVG . Embedding images cre- 
ates larger SVG files, whereas linking allows you to swap and edit the images easily . 

4 Click OK . 

Animate exports an SVG file with any image data encoded in the text file . An SVG 
document is a text file marked up much like an HTML document . All the visual 
information, including corner points, curves, text, and color information, is encoded 
in a compact form . 

When you open an SVG file in your browser, it renders the image, and all the vector 
information is preserved . Curves remain sharp even up close, and any static text in 
your composition is selectable . 


