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13
APPLYING APPEARANCE 
ATTRIBUTES AND 
GRAPHIC STYLES

Lesson overview
In this lesson, you’ll learn how to do the following: 

•	 Create and edit an appearance attribute.

•	 Add a second stroke to an object.

•	 Reorder appearance attributes and apply them to layers.

•	 Copy, turn on and off, and remove appearance attributes.

•	 Save an appearance as a graphic style.

•	 Apply a graphic style to an object and a layer.

•	 Apply multiple graphic styles to an object or layer.

•	 Align content to the pixel grid.

•	 Work with the Slice and Slice Selection tools.

•	 Use the Save For Web command.

This lesson takes approximately an hour to complete. If needed, remove 
the previous lesson folder from your hard disk and copy the Lesson13 
folder onto it.
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Without changing the structure of an object, you 
can change its look using appearance attributes, 
including fills, strokes, effects, transparency, and 
blending modes. You can save appearance attributes 
as graphic styles and apply them to another object.  
You can also edit an object that has a graphic style 
applied to it and then edit the graphic style—an 
enormous time-saver! 

Welcome to 5 Little Duckies - the city’s 
premier baby clothing and gift store!

Furniture
Registry

ContactToys

Clothing

Sign In  |  New Customers  |  View Shopping Cart Search Go
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Getting started
In this lesson, you’ll enhance the design for a web page by applying appearance 
attributes and graphic styles to the type, background, and buttons. Before you 
begin, you’ll restore the default preferences for Adobe Illustrator CS6. Then, you 
will open the finished art file for this lesson to see what you’ll create.

1	 To ensure that the tools and panels function exactly as described in this lesson, 
delete or deactivate (by renaming) the Adobe Illustrator CS6 preferences file. 
See “Restoring default preferences” on page 3.

2	 Start Adobe Illustrator CS6.

�	Note:  If you have not already done so, copy the Lesson13 folder from the Lessons folder on the 
Adobe Illustrator CS6 Classroom in a Book CD onto your hard disk. See “Copying the Classroom in a 
Book files” on page 2.

3	 Choose File > Open. Locate the L13end.ai file 
in the Lesson13 folder in the Lessons folder 
that you copied onto your hard disk, to view 
the finished artwork. Leave the file open for 
reference, or choose File > Close.

�	Note:  If a color profile warning dialog box appears, 
click OK.

The design for the completed web page includes several graphic styles and 
effects, including gradients, drop shadows, and other graphics. This lesson 
contains a fictitious business name, made up for the purposes of the project.

4	 Open the L13start.ai file in the Lesson13 
folder, located in the Lessons folder on your 
hard disk.

�	Note:  If a color profile warning dialog box appears, 
click OK.

5	 Choose File > Save As. In the Save As dialog 
box, navigate to the Lesson13 folder and 
open it. Name the file webstore.ai. Leave the Save As Type option set to Adobe 
Illustrator (*.AI) (Windows) or the Format option set to Adobe Illustrator 
(ai) (Mac OS), and click Save. In the Illustrator Options dialog box, leave the 
Illustrator options at their default settings and then click OK.

6	 Choose View > Fit Artboard In Window.

7	 Choose Window > Workspace > Reset Essentials.

�	Note:  If you don’t see “Reset Essentials” in the Workspace menu, choose Window > Workspace > 
Essentials before choosing Window > Workspace > Reset Essentials.

Welcome to 5 Little Duckies - the city’s 
premier baby clothing and gift store!

Furniture
Registry

ContactToys

Clothing

Sign In  |  New Customers  |  View Shopping Cart Search Go

�	Note:  In Mac OS, 
when opening lesson 
files, you may need to 
click the round, green 
button in the upper-left 
corner of the Document 
window to maximize 
the window’s size.
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Using appearance attributes
You can apply appearance attributes to any object, group, or layer by using effects, 
the Appearance panel, and the Graphic Styles panel. An appearance attribute is 
an aesthetic property—such as a fill, stroke, transparency, or effect—that affects 
the look of an object but does not affect its basic structure. An advantage of using 
appearance attributes is that they can be changed or removed at any time without 
changing the underlying object or any other attributes applied to the object in the 
Appearance panel (Window > Appearance).

1	 Click the Appearance panel icon ( ) on the right side of the workspace to 
expand the Appearance panel.

2	 Select the Selection tool, and click to select the large, yellow number 5 next  
to the duck.

The different options available in the Appearance panel are described below:

If you apply the Drop Shadow effect to an object, in the Appearance panel you can 
turn off the Drop Shadow effect, duplicate it, edit it, delete it, and more. You can 
also copy that effect and apply it to other shapes, groups, or layers. You can even 
save it as a graphic style and use it for other objects or files.

Editing and adding appearance attributes
You’ll start by changing the basic appearance of the selected number 5, using the 
Appearance panel.

1	 With the yellow number 5 still selected and with 
the Appearance panel showing, select the Fill 
attribute row by clicking to the right or left of 
the yellow Fill color box.

Selecting an attribute row lets you change the 
properties of only that attribute in the  
selected artwork.

A. Selected object and 
thumbnail

B. Visibility column

C. Link to options

D. Add New Stroke

E. Add New Fill

F. Add New Effect

G. Clear Appearance

H. Duplicate Selected 
Item

I. Delete Selected Item

J. Indicates an effect 
applied

J

A

B

C

D E F G H I



ptg7971238

378  LESSON 13  Applying Appearance Attributes and Graphic Styles

2	 In the Appearance panel, click the Fill 
color box in the Fill attribute row. In 
the Swatches panel that appears, click 
the swatch named Blue. Press the 
Escape key to hide the swatches.

3	 Click the triangle to the left of the 
word “Fill” in the Appearance panel. 
You will see the Opacity option. Click 
the word “Opacity” to reveal the 
Transparency panel. Choose 100% from the Opacity menu. Press the Escape 
key to hide the Transparency panel and to return to the Appearance panel.

You can change some appearance attributes, like Opacity, in the Appearance 
panel or elsewhere in the workspace.

4	 In the Appearance panel, click the phrase “1 pt” in the Stroke Appearance panel 
row. Click the underlined word “Stroke” to reveal the Stroke panel. Change the 
Stroke weight to 3 pt. Click the Align Stroke To Outside button ( ). Press the 
Escape key to hide the Stroke panel. Leave the Appearance panel open.

When you select certain attributes in the Appearance panel, like Stroke, new 
options appear. You can change the Stroke color and the Stroke weight without 
clicking the word “Stroke” to reveal the Stroke panel.

5	 Choose Select > Deselect, and then choose File > Save.
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Adding another stroke
Artwork in Illustrator can have more than one stroke and fill applied to them to 
add interesting design elements. You’ll now add another stroke to an object, using 
the Appearance panel.

1	 Select the Zoom tool ( ), and drag a marquee across the shirt shape 
underneath the “Clothing” text.

2	 With the Selection tool, click to select the shirt shape. In the Appearance panel, 
change the Stroke weight to 5 pt. Click the Stroke color box ( ), and select the 
swatch named Medium gray.

3	 Click the underlined word “Stroke,” and click the Align Stroke To Outside 
button ( ). Press the Escape key to hide the Stroke panel, leaving the 
Appearance panel open.

Clothing

�	Note:  Depending on your operating system, the selection color of objects (the bounding box) 
may be different and that’s okay.

4	 In the Appearance panel, click the Add New Stroke button ( ) at the bottom of 
the panel. A stroke is added above the original stroke row. It has the same color 
and stroke weight as the first stroke.

5	 For the new stroke, leave Stroke 
weight at 5 pt. Click the Stroke 
color box in the new appearance 
row to open the Swatches panel. 
Select Orange for the color. Press 
Enter or Return to close the 
Swatches panel and to return to 
the Appearance panel.

Next, you will add an effect to change the offset of the stroke by bringing it toward 
the center of the shirt shape.

6	 With the Stroke attribute row still selected, click the Add New Effect button 
( ) at the bottom of the Appearance panel. Choose Path > Offset Path from 
the menu that appears.

�	Tip:  Other ways to 
close panels that appear 
in the Appearance 
panel, such as the 
Color panel, include 
pressing the Escape key 
or clicking the Stroke 
attribute row.
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7	 Select Preview in the Offset Path dialog box 
to see the effect of offsetting as you change 
the values. Change Offset to -1 px, and then 
click OK.
1

8	 In the Appearance panel, click the arrow to 
the left of the orange Stroke row to reveal the 
Offset Path and Opacity attributes. Click the 
word “Opacity,” and choose 70% from the Opacity menu. Press the Escape key 
to hide the Transparency panel.

Clothing

9	 Deselect the eye icon ( ) to the left of Offset Path to hide that effect. Notice 
that the stroke for the shirt shape on the artboard changes. Select the Visibility 
column to apply the Offset Path effect again.

By clicking the eye icon in the Appearance panel, you disable an attribute 
without deleting it.

10	Choose Select > Deselect, and then choose File > Save.

Adding another fill
You’ll now add another fill to an object, using the Appearance panel. This can be a 
great way to achieve interesting design effects with just one object.

1	 Choose View > Fit Artboard In Window.

2	 With the Selection tool ( ), click the orange gradient-filled shape behind the  
“5 Little Duckies” text shapes to select it.

3	 In the Appearance panel, click the Fill attribute row to select it.

4	 Click the Add New Fill button ( ) at the bottom of the panel.

A new fill is added above the existing fill in the Appearance panel.

5	 With the new fill attribute row selected, click the Fill color box and select the 
Duck pattern. This new fill will cover the existing orange/yellow gradient fill. 
Press the Escape key to hide the swatches.

�	Tip:  You can view 
all hidden attributes 
by choosing Show 
All Hidden Attributes 
from the Appearance 
panel menu.
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Sign 

6	 Click the triangle to the left of the selected Fill row to reveal the word “Opacity,” 
and scroll down in the panel if necessary. Click the underlined word “Opacity” 
to reveal the Transparency panel.

7	 In the Transparency panel, choose Multiply from the Blending Mode menu. 
Change the Opacity to 10%, and press Enter or Return to close the panel.

Sign 

8	 Choose File > Save, and leave the shape selected.

Reordering appearance attributes
The ordering of the appearance attribute rows can greatly change how your artwork 
looks. In the Appearance panel, fills and strokes are listed in stacking order; top 
to bottom in the panel correlates to front to back in the artwork. You can reorder 
attribute rows in a way similar to dragging layers in the Layers panel, to rearrange 
the stacking order. Now, you’ll change the appearance of the artwork by reordering 
attributes in the Appearance panel.

1	 Resize the Appearance panel so that you can view all its contents. Click the 
triangle ( ) to the left of all of the appearance rows to hide their properties.

2	 Drag the new Fill attribute row (with the Duck 
pattern swatch applied) below the original Fill 
attribute row.

Moving the new Fill attribute below the original 
Fill attribute changes the look of the artwork. The 
original yellow/orange gradient fill is now covering 
the new fill.

�	Note:  The 
thumbnail you see 
in the transparency 
options may look 
different, depending on 
your operating system.
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3	 Choose Edit > Undo Move Appearance Item so that the new Fill row is once 
again between the stroke and original Fill rows in the Appearance panel.

Applying an appearance to a layer
You can also apply simple appearance attributes to layers. For example, to make 
everything on a layer 50% opaque, target that layer and change the opacity.

Next, you’ll target a layer and add a drop shadow.

1	 Click the Layers panel icon ( ) to open the panel. In the Layers panel, click the 
triangle to the left of the Buttons layer to view its content, if necessary.

2	 Click the target icon ( ) to the right of the circles sublayer.

3	 Open the Appearance panel, and notice that it says Layer at the top. This 
indicates that any attributes applied will be applied to all content on that layer. 
When you select items that contain other items, such as a layer or group, the 
Appearance panel displays a Contents item, which you can double-click to edit.

4	 Click the Add New Effect button ( ) at the bottom of the Appearance panel, 
and choose Stylize > Drop Shadow.

5	 In the Drop Shadow dialog box, change the Opacity to 25%, the X Offset  
to -2 px, the Y Offset to 2 px, and the Blur to 2 px. Click OK.

6	 Click the Layers panel icon ( ), and notice that the target icon now has a shaded 
center ( ), indicating that the layer has appearance attributes applied to it.

7	 Choose Select > Deselect, and then choose File > Save.

�	Note:  The layer 
colors you see may be 
different, depending on 
your operating system, 
and that’s okay.
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Using graphic styles
A graphic style is a saved set of appearance attributes that you can reuse. By 
applying graphic styles, you can quickly and globally change the appearance of 
objects and text.

The Graphic Styles panel (Window > Graphic Styles) lets you create, name, save, 
apply, and remove effects and attributes for objects, layers, and groups. You can 
also break the link between an object and an applied graphic style to edit that 
object’s attributes without affecting other objects that use the same graphic style.

For example, if you have a map that uses a shape to represent a city, you can create 
a graphic style that paints the shape green and adds a drop shadow. You can then 
use that graphic style to paint all the city shapes on the map. If you decide to use 
a different color, you can change the fill color of the graphic style to blue. All the 
objects that use that graphic style are then updated to blue.

Creating and saving a graphic style
Now, you’ll save and name a new graphic style using the appearance attributes you 
just specified for the shirt shape below the “Clothing” text. You will then apply the 
same appearance attributes to the other button shapes.

1	 Choose Reset Essentials from the workspace switcher in the Application bar.

2	 Click the Graphic Styles panel icon ( ) on the right side of the workspace to 
open the Graphic Styles panel.

3	 With the Selection tool ( ), click to select 
the shirt shape beneath the “Clothing” text.

�	Note:  Depending on your operating system, the 
bounding box and edges (the yellow outlines in the 
figure) of some selected objects may be a different color, 
and that’s okay.

�	Tip:  To create a 
graphic style, you can 
also click to select the 
object that you are 
making the graphic 
style from. In the 
Appearance panel, 
drag the appearance 
thumbnail at the top 
of the listing into the 
Graphic Styles panel.

Clothing

A. Graphic style 
thumbnail

B. Graphic Styles 
Libraries Menu

C. Break Link To 
Graphic Style

D. New Graphic Style

E. Delete Graphic Style

A

B C D E
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4	 In the Graphic Styles panel, click the New Graphic Style button ( ) at the 
bottom of the panel.

5	 In the Graphic Styles panel, double-click the new Graphic Style thumbnail. In 
the Graphic Style Options dialog box, name the new style Icons. Click OK.

6	 Click the Appearance panel icon and, at the top 
of the Appearance panel, you will see Path: Icons. 
This indicates that a graphic style called Icons is 
applied to the selected artwork (a path).

7	 Choose Select > Deselect and then File > Save.

Applying a graphic style to an object
Graphic styles can be easily applied to other objects. Next, you will apply the Icons 
graphic style you just created to another shape.

1	 With the Selection tool ( ), click to select the baby rattle shape to the left of the 
text “Toys.”

2	 Click the Graphic Styles panel tab to reveal the panel, and then click the graphic 
style named Icons to apply its attributes.

You can also apply a graphic style by dragging its thumbnail directly from the 
Graphic Styles panel onto an object, even if the object isn’t selected.

3	 Choose File > Save.

Create a new graphic style.	 Double-click the graphic style.	 Rename the graphic style.
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Replacing graphic style attributes
Once you create a graphic style, you can still edit the object that the style is applied 
to. You can also update a graphic style, and all artwork with that style applied will 
update their appearance as well.

1	 With the Selection tool ( ), click to select the shirt shape again. In the Graphic 
Styles panel, you will see that the Icons graphic style thumbnail is highlighted 
(has a border around it), indicating that it is applied.

2	 Click the Appearance panel tab. Change the stroke color of the orange stroke 
to white. Click the Graphic Styles panel tab to see that the graphic style is no 
longer highlighted, which means that the graphic style is no longer applied.

3	 Press the Alt (Windows) or Option (Mac OS) key, and drag the shirt shape on 
top of the Icons graphic style thumbnail in the Graphic Styles panel. Release the 
mouse button and then the modifier key when the thumbnail is highlighted.

4	 Choose Select > Deselect.

5	 With the Selection tool, Shift-click the shape behind the text “Furniture,” the white 
shape above the text “Registry,” and the white shape above the text “Contact.”

6	 Click the Icons graphic style in the Graphic Styles panel to apply its attributes.

7	 Choose Select > Deselect and then File > Save.

Applying a graphic style to a layer
When a graphic style is applied to a layer, everything added to that layer has that 
same style applied to it. Now, you’ll apply a new graphic style to a layer.

1	 Click the Appearance panel tab. You will see  
No Selection: Icons at the top of the panel 
(you may need to scroll up). When you apply 
appearance settings, graphic styles, and more to 
artwork, the next shape you draw will have the 
appearance settings listed in the Appearance panel.

Clothing

Change the stroke color.	 Alt-drag (Windows) or Option-drag (Mac OS) the shape onto the style.
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2	 Click the Clear Appearance button ( ) at the bottom of the Appearance panel. 
Select the No Selection appearance name or thumbnail at the top of the panel.

The Clear Appearance button removes all appearance attributes applied to an 
object, including any stroke or fill. By clicking the Clear Appearance button with 
nothing selected, you are setting the default appearance for new shapes.

3	 Click the Add New Effect button ( ), and choose Stylize > Drop Shadow.

4	 In the Drop Shadow dialog box, change the Opacity to 100%, the X Offset  
to -2 px, the Y Offset to 2 px, and the Blur to 2 px. Leave the rest of the settings 
at default, and click OK. In the Appearance panel, notice that Drop Shadow 
appears in the list. You may need to scroll in the Appearance panel to see it listed.

A new graphic style is created from the current appearance attributes displayed 
in the Appearance panel, if nothing is selected in the Document window.

5	 Click the Graphic Styles panel tab. Alt-click 
(Windows) or Option-click (Mac OS) the 
New Graphic Style button ( ), and name the 
new style Icons shadow in the Graphic Style 
Options dialog box. Click OK.

Pressing the modifier key opens the dialog box 
when you click. The graphic style thumbnail 
shows a box with a slash on the lower-left corner of the thumbnail. This 
indicates that the graphic style has no stroke and no fill.

Now, you’ll target the bases sublayer to apply a drop shadow to all the shapes on 
that layer. Targeting selects the path(s) on that layer in the artwork.

6	 Click the Layers panel icon ( ) on the right side of the workspace to open the 
Layers panel.

7	 In the Layers panel, click the triangle ( ) to the left of the Buttons layer to 
expand the layer, if it isn’t already. Click the target icon ( ) to the right of the 
bases sublayer name.

Clear the appearance.	 Add a drop shadow.	 The result.
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8	 Click the Graphic Styles panel icon ( ), and then click the Icons shadow style 
thumbnail to apply the style to the layer and all its contents. Keep the shapes 
selected on the artboard.

Clothing

Select the layer target icon.	 Apply a graphic style.	 The result.

If you apply multiple graphic styles to an object, the latest graphic style 
overwrites the previous. If you apply a graphic style to artwork and then apply a 
graphic style to the layer (or sublayer) that it’s on, the graphic style formatting is 
added together and is cumulative.

Notice that the shape above the text “Registry” does not have the drop shadow 
applied. That’s because that shape is not on the bases sublayer.

9	 Click the Layers panel icon ( ), and drag the 
<Path> object at the top of the Buttons layer 
on top of the bases sublayer to add it to that 
sublayer and to apply the Icons shadow graphic 
style to the Registry shape.

10	Choose Select > Deselect and then File > Save.

Editing a graphic style applied to a layer
Next, you will edit the drop shadow applied to the layer.

1	 Click the Appearance panel icon ( ) on the right side of the workspace to open 
the Appearance panel.

2	 With the Selection tool, click to select the shirt shape beneath the “Clothing” text.

In the Appearance panel, notice the name 
Layer: Icons shadow at the top of the panel. The 
Appearance panel shows that the shirt shape is on 
a layer with a graphic style called Icons shadow 
applied to it.

3	 Click the words Layer: Icons shadow to access 
the Drop Shadow effect applied to the layer. 
This also selects all of the shapes on the layer.

�	Tip:  You can 
also select the bases 
sublayer target icon in 
the Layers panel and 
then edit the effect in 
the Appearance panel.
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4	 Click the underlined text Drop Shadow in the 
Appearance panel and, in the Drop Shadow 
dialog box, change Opacity to 25%. Click OK. 
Leave the Appearance panel showing.

5	 Choose Select > Deselect, and then choose  
File > Save.

Applying an existing graphic style
You can also apply graphic styles to your artwork from graphic style libraries that 
come with Illustrator CS6. Now, you’ll add graphic styles to a button in the design.

1	 Choose View > Fit Artboard In Window.

Now, you’ll apply an existing graphic style to the Go button that is located off the 
upper-right corner of the artboard.

2	 Click the Graphic Styles panel tab. Click the 
Graphic Styles Libraries Menu button ( ), and 
choose Illuminate Styles. Scroll down in the 
Illuminate Styles panel, and click the Illuminate 
Yellow graphic style. Clicking that style adds it to 
the Graphic Styles panel for the document.

3	 At the bottom of the Illuminate Styles panel, click 
the Graphic Styles Libraries Menu button ( ) 
and choose Additive. In the Additive panel, click 
the Round Corners 10 pt graphic style thumbnail 
to add it to the Graphic Styles panel as well. 
Close the Additive panel.

4	 With the Selection tool ( ), click to select the white rectangle off the upper-
right corner of the artboard (to the right of the Search field). Be careful not to 
select the white text “Go” that is on top of it.

5	 Right-click (Windows) or Control-click (Mac OS), and hold down the mouse 
button on the Illuminate Yellow style thumbnail in the Graphic Styles panel to 
preview the graphic style on the shape. Release the mouse button (and then the 
Control key on Mac OS) when finished.

Previewing a graphic style is a great way to see how the graphic style will affect 
the selected object, without actually applying it.

6	 Click the Illuminate Yellow graphic style in the Graphic Styles panel to apply it 
to the shape. Click the Graphic Styles panel tab to collapse the panel group.

�	Tip:  Use the arrows 
at the bottom of 
the Illuminate Styles 
library panel to load 
the previous or next 
graphic styles library in 
the panel.

�	Note:  When you 
click a graphic style 
from a library, the 
graphic style is added to 
the Graphic Styles panel 
for that document.
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rch Gorch Go

Select the white rectangle.	 Preview the graphic style.	 The result.

7	 Choose File > Save, and leave the shape selected.

�	Note:  You may see a warning icon appear on the end of the Control panel. That’s okay. This is a 
helpful indicator that the topmost fill/stroke is not active.

Applying multiple graphic styles
You can apply a graphic style to an object that already has a graphic style applied. 
This can be useful if you want to add properties to an object from another  
graphic style.

1	 With the rectangle behind the text “Go” still selected, click the Style menu in 
the Control panel. In the Graphic Styles panel that appears, click to apply the 
Round Corners 10 pt graphic style to the Go button shape.

Notice that the fills and the stroke are no longer visible. Graphic styles replace 
the formatting on selected objects, by default.

2	 Choose Edit > Undo Graphic Styles.

3	 Click the Style menu in the Control panel again, and Alt-click (Windows) or 
Option-click (Mac OS) the Round Corners 10 pt graphic style.

Notice that, on the Go button, the fills and stroke are preserved and that the 
corners are rounded as well (you may need to zoom in). Alt-clicking (Windows) 
or Option-clicking (Mac OS) adds the graphic style formatting to the existing 
formatting, rather than replacing it.

GoGo

Apply the graphic style.	 The result.	 The final result.

4	 With the Selection tool ( ), Shift-click the text “Go” and choose  
Object > Group.

�	Note:  If the Style 
menu doesn’t appear in 
the Control panel, open 
the Graphic Styles panel 
by clicking its icon on 
the right side of the 
workspace.



ptg7971238

390  LESSON 13  Applying Appearance Attributes and Graphic Styles

5	 Click the X, Y, W, or H link in the Control panel to reveal the Transform panel 
(Window > Transform). Select Scale Strokes & Effects at the bottom of the 
Transform panel.

6	 In the Transform panel, click the Constrain Width And Height Proportions 
button ( ). Change the width (W) to 25. Press Enter or Return to change the 
height as well, and hide the Transform panel.

7	 Drag the button group to the right of the Search field, using the Smart Guides to 
align it.

8	 Choose Select > Deselect and then File > Save.

Applying a graphic style to text
Next, you’ll apply an existing graphic style to some text.

1	 With the Selection tool ( ), click to select the “Clothing” text. Choose  
Select > Same > Fill & Stroke to select all five text objects.

2	 Click the Graphic Styles panel icon ( ) to expand the panel, if necessary. 
Choose Override Character Color from the Graphic Styles panel menu ( ), if 
it’s not already selected.

When you apply a graphic style to type, the fill color of the text overrides the fill 
color of the graphic style. To prevent that, choose Override Character Color.

3	 Choose Use Text For Preview from the Graphic Styles panel menu ( ).

4	 In the Graphic Styles panel, right-click (Windows) or Control-click (Mac OS) 
and hold down the mouse button on the Blue Neon graphic style to preview 
the graphic style on the text. Release the mouse button (and the Control key on 
Mac OS), and then click the Blue Neon graphic style to apply it.

If Override Character Color had been deselected, the fill would still be black.

Select Scale Strokes & Effects.	 Change the width.	 Drag the button into position.
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5	 Click the Appearance panel tab, and then click the Clear Appearance  
button ( ) at the bottom of the panel to remove the graphic style formatting.

6	 Choose Select > Deselect and then File > Save.

Copying and removing graphic styles
When you create several graphic styles and appearances, you may want to use 
them on other objects in your artwork. You can use the Graphic Styles panel, the 
Appearance panel, the Eyedropper tool, or the Live Paint Bucket tool to apply and 
copy appearance attributes. Now, you’ll use the Layers panel to copy an attribute 
from one layer to another.

1	 Expand the Layers panel to see all the layers. With the triangle to the left of the 
Buttons layer expanded, Alt-drag (Windows) or Option-drag (Mac OS) the target 
icon ( ) from the bases sublayer onto the target icon of the text sublayer above it.

Using the Alt (Windows) or Option (Mac OS) key as you drag, copies 
appearance attributes from one layer to another. The shaded target icon ( ) 
indicates that the layer contains appearance attributes. To move, not copy, an 
appearance or style from one layer or object to another, drag the target icon. 
The text now has the same subtle drop shadow applied.

Now, you’ll remove the appearance attributes from that layer, using the Layers panel.

2	 In the Layers panel, click the target icon to the right of the text sublayer.

3	 Drag the target icon to the Trash button ( ) at the bottom of the Layers panel 
to remove the appearance attribute. Click the Layers panel tab to collapse it.
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You can also remove attributes of a selected object or layer in the Appearance 
panel. To do this, select the object and then choose Reduce To Basic 
Appearance from the panel menu. This removes all appearance attributes 
except a single fill and stroke.

4	 Choose Select > Deselect, and then File > Save.

Creating web graphics
Creating content for the web requires that vector content be converted to raster 
content. You can do this using the Save For Web command. Images can be saved in 
a multitude of file formats, such as GIF, JPEG, and PNG. GIF, JPEG, and PNG are 
optimized for use on the web and are compatible with most browsers, yet they each 
have different capabilities. The key to the effective use of images on a website is finding 
the balance of resolution, size, and color to achieve optimal quality.

�	Note:  This section is meant as an introduction to the main tools and processes for saving web 
content from Illustrator and is not a comprehensive guide. To learn more about working with web 
graphics, search for “File formats for exporting artwork“ in Illustrator Help (Help > Illustrator Help).

Aligning content to the pixel grid
It is critical that raster images look sharp, especially standard web graphics at 
72-ppi (pixels per inch) resolution. To enable web designers to create pixel-
accurate designs, you can align artwork to the pixel grid. The pixel grid is a grid of 
72 squares per inch, vertically and horizontally, that is viewable when you zoom to 
600% or higher when Pixel Preview mode is enabled (View > Pixel Preview).

When the pixel-aligned property is enabled for an object, all the horizontal and 
vertical segments in the object get aligned to the pixel grid, which provides a crisp 
appearance to strokes. When you create a new document, you can set the Align 
New Objects To Pixel Grid option at the document level by choosing Web from the 
Profile menu in the New Document dialog box. This makes all artwork (that is able 
to be aligned to the pixel grid) align to the pixel grid automatically. You can also 
align content to the pixel grid later, as you will do in this section.

1	 With the webstore.ai file still 
open, choose File > New. In 
the New Document dialog box, 
choose Web from the Profile 
menu. Click the triangle to the 
left of the Advanced content, 
toward the bottom of the  
dialog box.

�	Note:  To learn more 
about what the term 
raster means, see the 
section “Vector versus 
bitmap graphics” in 
Lesson 15, “Combining 
Illustrator CS6  
Graphics with Other 
Adobe Applications.”
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In the Advanced settings, you can see that the Color Mode is RGB for all 
artwork you create, the Raster Effects are 72 ppi, and Align New Objects To 
Pixel Grid is selected.

2	 Click Cancel.

3	 In the webstore.ai file, choose File > Document Color Mode and you will see 
that RGB is selected.

After you create a document, you can change the document color mode. This 
sets the default color mode for all new colors you create.

4	 Select the Zoom tool ( ), and drag a marquee around the text shapes “Little” to 
the right of the duck in the header, to zoom in closely. This is text that has been 
converted to outlines (paths).

5	 Choose View > Pixel Preview to preview a rasterized version of the design and 
the pixel grid.

The artwork in Preview mode	 The artwork in Pixel Preview mode

By zooming in to at least 600%, and with Pixel Preview turned on, you can see 
a pixel grid appear, as in the figure. The pixel grid divides the artboard into 
1‑point (1/72 inch) increments.

6	 With the Selection tool ( ), click to select the group of text shapes that begins  
with “Little.”

7	 Click the word “Transform” 
(or X, Y, W, or H) in the 
Control panel, and select 
Align To Pixel Grid at the 
bottom of the Transform 
panel. Deselect and select 
Align To Pixel Grid to see the 
change on the edge of the  
text shapes.

8	 Choose View > Fit Artboard In Window.

9	 Choose Select > Object > Not Aligned To Pixel Grid to select all artwork in the 
document that is able to be, but is not currently, aligned to the pixel grid.

10	Click the word “Transform” in the Control panel, and select Align To Pixel 
Grid. Leave the Transform panel showing.

�	Tip:  You can turn 
off the pixel grid 
by choosing Edit > 
Preferences > Guides 
& Grid (Windows) or 
Illustrator > Preferences > 
Guides & Grid (Mac OS) 
and deselecting Show 
Pixel Grid (Above 600% 
Zoom).

�	Note:  Objects that 
are pixel-aligned, but 
do not have any straight 
vertical or horizontal 
segments, are not 
modified to align to the 
pixel grid. For example, 
because a rotated 
rectangle does not 
have straight vertical or 
horizontal segments, 
it is not nudged to 
produce crisp paths 
when the pixel-aligned 
property is set for it.
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11	Choose Align New Objects To Pixel Grid from the Transform panel menu ( ). 
Press the Escape key to hide the Transform panel.

This sets all new artwork to be aligned to the pixel grid automatically. Once again, if you 
had chosen the Web Profile when creating a document, this would be set already.

12	Choose Select > Deselect, and then choose File > Save.

Text anti-aliasing
The Character panel in Illustrator provides the 
following text anti-aliasing options: None, Sharp, 
Crisp, and Strong. You can set anti-aliasing options for 
each text frame. These text anti-aliasing attributes get 
saved as part of the document.

While exporting to web formats like JPEG and GIF 
using the File > Save For Web command, the following 
options are available in the anti-aliasing drop-down 
list: None, Art Optimized, and Type Optimized.

•	 Art Optimized option produces raster for each 
of these formats in the same way as in earlier 
versions. However, text anti-aliasing options are 
not honored while rasterizing the artwork in this case.

•	 Type Optimized option honors the newly introduced anti-aliasing options for 
the text frames in the raster produced.

—From Illustrator Help

Slicing content
If you create artwork on an artboard and choose File > Save For Web, Illustrator 
creates a single image file the size of the artboard. You can create multiple 
artboards for artwork that each contain a piece of the web page, like a button, and 
save each artboard as a separate image file. 

You can also design your artwork on an artboard and slice the content. In 
Illustrator, you can create slices to define the boundaries of different web elements 
in your artwork. For example, if you design an entire web page on an artboard 
and there is a vector shape that you want to save as a button for your website, that 
artwork can be optimized in GIF format, while the rest of the image is optimized as 
a JPEG file. You can isolate the button image by creating a slice. When you save the 
artwork as a web page using the Save For Web command, you can choose to save 
each slice as an independent file with its own format and settings.

Next, you will create a new layer that will contain the slices and then you will create 
slices for different parts of the artwork.

�	Note:  To learn more 
about creating slices, 
search for “Create slices“ 
in Adobe Illustrator 
Help (Help >  
Illustrator Help).
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1	 Click the Layers panel icon ( ) to open the 
Layers panel. Click to select the Top nav layer. 
Alt-click (Windows) or Option-click (Mac OS) 
the Create New Layer button ( ) at the bottom 
of the Layers panel. In the Layer Options dialog 
box, change the name of the layer to Slices and 
click OK. Make sure that the new layer named 
Slices is selected.

When you create slices, they are listed in the 
Layers panel and can be selected, deleted, 
resized, and more. It helps to keep them on their own layer so that you can 
more easily manage them, but this isn’t necessary.

2	 Select the Slice tool ( ) in the Tools panel. Click and drag a slice around the 
duck, the number 5, and the text “Little Duckies.” Don’t worry about it fitting 
perfectly right now; you will edit it later.

When you create a slice, Illustrator slices the surrounding artwork into 
automatic slices to maintain the layout of the page. Auto slices account for the 
areas of your artwork that you did not define as a slice. Illustrator regenerates 
auto slices every time you add or edit your own slices. Also, notice the 
number 3 in the corner of the slice you created. Illustrator numbers slices from 
left to right and top to bottom, beginning in the upper-left corner of the artwork.

Next, you will create a slice based on selected content.

3	 Select the Selection tool ( ) and click the Go button group in the upper-right 
corner of the artboard. You may want to zoom in.

4	 Select the Slices layer in the Layers panel to place the new slice on that layer.

5	 Choose Object > Slice > Create  
From Selection.

Illustrator can create slices based on 
guides you create or on content that 
you select in the Document window.

�	Note:  To learn 
more about creating 
layers, see the section 
“Creating layers” in 
Lesson 8, “Working  
With Layers.” The new 
layer you create may 
have a different layer 
color and that’s okay.

�	Tip:  Use the 
Object > Slice > 
Make command 
when you want the 
slice dimensions to 
match the boundary 
of an element in your 
artwork. If you move or 
modify the element, the 
slice area automatically 
adjusts to encompass 
the new artwork.
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Selecting and editing slices
Editing user slices is necessary, for instance, when sliced content changes or when 
what is included in the slice needs to change.

1	 Choose View > Fit Artboard In Window.

2	 Select the Slice Selection tool ( ) from the Slice tool group in the Tools panel 
by clicking and holding down on the Slice tool ( ).

3	 Click in the center of the first slice you created over the “5 Little Duckies” text. 
The selected slice is highlighted, and four corner bounding points appear.

The Slice Selection tool allows you to edit slices you’ve created using the different 
methods. You can also select a user slice with the Selection or Direct Selection 
tools by clicking the stroke (edge) of the slice or from within the Layers panel.

4	 Position the pointer over the left edge of the selected slice. When a double arrow 
appears, click and drag to the left until it snaps to the left edge of the artboard.

5	 Position the pointer over the lower-right bounding point of the selected slice, and 
click and drag the slice to tighten it around the “5 Little Duckies” text, if necessary.

When slicing content, you should contain all appearance attributes, like drop 
shadows, in the slice area. This can be difficult if the shadow is blurred quite a bit. 
Using the Object > Slice > Create From Selection command will create a slice that 
surrounds all appearance properties, like effects, if those effects are applied directly 
to the artwork and not to the layer the artwork is on. Using the Slice Selection tool, 
you can click and drag a slice, copy and paste it, delete it, and much more.

6	 Choose Select > Deselect, and then choose View > Lock Slices so that you 
cannot select them. Choose File > Save.

Using the Save For Web command
After having sliced your artwork, if necessary, you can then optimize that artwork 
for use on the web. You can use the File > Save For Web command to select 
optimization options and to preview optimized artwork. This is the last step in the 
process of creating content for the web.

1	 Choose View > Hide Slices.

�	Note:  To learn more 
about editing slices, 
search for “Create slices“ 
in Adobe Help (Help > 
Illustrator Help).
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While working on your artwork, you don’t have to have the slices showing. This 
can make it so that you can concentrate on selecting artwork without selecting 
slices. You can also hide the layer that the slices are on if you created a layer for 
them in the Layers panel.

2	 Select the Selection tool ( ), and Shift-click the duck, the number 5, the “Little 
Duckies” text, and the Go button in the upper-right corner.

3	 Choose Object > Hide > Other Layers.

When you save the sliced content using the Save For Web command, all 
content that is showing in a slice will be flattened into a raster image. If you 
want to have transparency in the selected artwork (part of the image will be see-
through), you need to first hide what you don’t want to save. The areas where 
you see the artboard in a slice can be transparent, depending on the type of 
image you choose.

4	 Choose Select > Deselect, and then choose File > Save.

5	 Choose View > Show Slices, and ensure that the artwork and drop shadows are 
contained within the slice. If not, you can resize either slice.

6	 Choose File > Save For Web.

7	 In the Save For Web dialog box, click the 2-Up tab at the top of the dialog box 
to select that display option, if it’s not already selected.

This shows a split window with the original artwork on the left and the 
optimized artwork on the right.

8	 With the Slice Selection tool ( ) selected, click in the optimized area on the 
right. Click to select the slice that covers the duck and text artwork, if it isn’t 
selected already. You can tell when a slice is selected because of the light brown 
border around it.

9	 In the Preset area on the right side of the dialog box, choose PNG-24 from the 
Optimized File Format menu (below Name).

�	Note:  To resize the 
slices, you would need 
to make sure that they 
are unlocked. Choose 
View > Lock Slices (if  a 
checkmark appears to 
the left of the menu 
item, they are locked).
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You can choose from four file formats, including GIF, JPEG, PNG-8, and  
PNG-24, as well as set the options for each in the Preset area. The available 
options change depending on the file format you select. If your image contains 
multiple slices that you are going to save, be sure to select each separately and 
to optimize all the slices.

10	Choose Selected Slices from the Export menu.

Any slices that you select in the Save For Web dialog box will be exported. You 
can select multiple slices, after you’ve assigned optimization settings to them, 
by Shift-clicking the desired slices. By choosing All User Slices from the Export 
menu, all slices that you created will be exported.

11	Click the Preview button in the lower-left corner of the dialog box to launch the 
default web browser on your computer and to preview the sliced content. After 
viewing the content, close the browser and return to Illustrator.

12	 In the Save For Web dialog box, click Save.

13	 In the Save Optimized As 
dialog box, navigate to 
the Lesson13 folder in the 
Lessons folder and open it. 
Change the name to logo, 
and click Save.

14	Navigate to your Lesson13 
folder, and open the images 
folder that Illustrator 
generated. In that folder, you 
will see the single image that 
is named according to the name entered in the Save Optimized dialog box, with 
the slice number appended to the end.

�	Tip:  When you select slices in the Save For Web dialog box and set optimization settings, they 
are saved with the slices in the file. That means, if you need to make a change to artwork and save 
that slice again, you can simply select the slice with the Slice Selection tool and choose File > Save 
Selected Slices. The saved optimization settings are applied to the artwork, and it is saved where  
you determine.

15	Return to Illustrator, and open the Layers panel. 
Choose Show All Layers from the panel menu ( ) to 
reveal blue icons on the white shapes.

16	Choose File > Save and then File > Close.

�	Note:  If nothing 
happens after clicking 
the Preview button, try 
clicking again. You may 
also need to click the 
Select Browser Menu 
button to the right of 
the Preview button and 
choose Edit List to add a 
new browser.
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