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14  
WORKING WITH SYMBOLS

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Work with existing symbols.

•	 Create a symbol.

•	 Modify and redefine a symbol.

•	 Use the Symbolism tools.

•	 Store and retrieve artwork in the Symbols panel.

•	 Work with symbols and Adobe Flash®.

This lesson takes approximately an hour to complete. If needed, remove 
the previous lesson folder from your hard disk and copy the Lesson14 
folder onto it.
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The Symbols panel lets you apply multiple objects 
by painting them on the page. Symbols used in 
combination with the Symbolism tools offer options 
that make creating repetitive shapes, such as blades 
of grass, easy and fun. You can also use the Symbols 
panel as a database to store artwork and to map 
symbols to 3D objects.
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Getting started
In this lesson, you’ll add symbols to a map. Before you begin, restore the default 
preferences for Adobe Illustrator. Then, open the file containing the finished 
artwork to see what you are going to create.

1	 To ensure that the tools and panels function exactly as described in this lesson, 
delete or deactivate (by renaming) the Adobe Illustrator CS6 preferences file. 
See “Restoring default preferences” on page 3.

2	 Start Adobe Illustrator CS6.

� Note: If you have not already done so, copy the Lesson14 folder from the Lessons folder on the 
Adobe Illustrator CS6 Classroom in a Book CD onto your hard disk. See “Copying the Classroom in a 
Book files” on page 2.

3	 Choose File > Open, and open the 
L14end.ai file in the Lesson14 folder in 
the Lessons folder on your hard disk.

If you want to view the finished map as 
you work, choose View > Zoom Out and 
adjust the window size. Use the Hand 
tool ( ) to move the artwork where you 
want it in the window. If you don’t want to leave the image open, choose  
File > Close.

To begin working, you’ll open an existing art file.

4	 Choose File > Open to open the 
L14start.ai file in the Lesson14 folder, 
located in the Lessons folder on your 
hard disk.

5	 Choose File > Save As. In the Save As 
dialog box, name the file map.ai and 
navigate to the Lesson14 folder. Leave 
the Save As Type option set to Adobe Illustrator (*.AI) (Windows) or the 
Format option set to Adobe Illustrator (ai) (Mac OS), and click Save. In the 
Illustrator Options dialog box, leave the Illustrator options at their default 
settings and then click OK.

6	 Choose Window > Workspace > Reset Essentials.

� Note: If you don’t see “Reset Essentials” in the Workspace menu, choose Window > Workspace > 
Essentials before choosing Window > Workspace > Reset Essentials.

7	 Double-click the Hand tool ( ) to fit the artboard in the window.
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� Note: In Mac OS, 
when opening lesson 
files, you may need to 
click the round, green 
button in the upper-left 
corner of the Document 
window to maximize 
the window’s size.
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Working with symbols
A symbol is a reusable art object that is stored in the Symbols panel (Window > 
Symbols). For example, if you create a symbol from a fish you drew, you can then 
quickly add multiple instances of that fish symbol to your artwork, which saves 
you from having to draw each fish again. All instances of the fish symbol are linked 
to the associated symbol in the Symbols panel, so you can easily alter them using 
Symbolism tools.

When you edit the original symbol, all instances of the fish that are linked to it are 
updated. You can turn that fish from blue to green instantly! Not only do symbols 
save time, but they also greatly reduce file size. They can also be used to create SWF 
files or artwork for Adobe Flash.

•	 Click the Symbols panel icon ( ) on the right side of the workspace. Take a 
minute to familiarize yourself with the parts of the Symbols panel.

Illustrator comes with a series of symbol libraries, which range from tiki icons 
to hair and fur. You can access the symbol libraries in the Symbols panel or by 
choosing Window > Symbol Libraries.

Using existing Illustrator symbol libraries
You will start by adding a symbol from an existing symbol library to the artwork.

1	 Choose View > Smart Guides to deselect Smart Guides.

2	 Click the Layers panel icon ( ) on the right 
side of the workspace to expand the Layers 
panel. Click the Symbols layer to make sure it 
is selected. Make sure that all of the layers are 
collapsed by clicking the triangles to the left 
of the layer names.

When adding symbols to a document, which 
layer is selected when they are added is the 
layer they become a part of.

3	 Click the Symbols panel icon ( ) on the right side of the workspace to expand 
the panel.

�	Note: The figure 
at left shows the 
Symbols panel with the 
map.ai file showing in 
the Document window.

A. Symbols

B. Symbol Libraries Menu

C. Place Symbol Instance

D. Break Link To Symbol

E. Symbol Options

F. New Symbol

G. Delete Symbol
A

B C D E F G
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4	 In the Symbols panel, click the Symbol 
Libraries Menu button ( ) at the bottom of 
the panel and choose Maps. The Maps library 
opens as a free-floating panel.

This library is external to the file that you are 
working on, but you can import any of the 
symbols into the document and use them in the artwork.

5	 Position the pointer over the symbols in the 
Maps panel to see their names as tool tips. 
Click the Rest Area symbol to add it to the 
Symbols panel for the document. Close the 
Maps panel.

Every document has a default set of symbols 
in the Symbols panel. When you add symbols to the panel, as you just did, they 
are saved with the active document only.

6	 Using the Selection tool ( ), drag the Rest Area symbol from the Symbols panel 
into the UNION PARK area (smaller green area) on the artboard. Drag  
another into the CENTRAL PARK (larger green area) on the artboard, and leave 
it selected.

Each time you drag a symbol onto the artboard, an instance of the Rest Area 
symbol is created. Next, you will resize one of the symbol instances on the page.

�	Tip: You can also copy a symbol instance on the artboard and paste as many as you need. This is 
the same as dragging a symbol instance out of the Symbols panel onto the artboard.

7	 Using the Selection tool and holding down the Shift key, drag the upper-right 
corner of the Rest Area symbol instance in the CENTRAL PARK area, up and 
to the right, to make it a little larger, while constraining its proportions. Release 
the mouse button and then the modifier key.

�	Note: The pointer that you see when dragging a symbol from the Symbols panel into the 
Document window may look different, and that’s okay.

�	Tip: If you want to 
see the symbol names 
rather than the symbol 
pictures, choose Small 
List View or Large List 
View from the Symbols 
panel menu ( ).

�	Note: Although you 
can transform symbol 
instances in many ways, 
specific properties of 
instances cannot be 
edited. For example, 
the fill color is locked 
because it is controlled 
by the original symbol 
in the Symbols panel.
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Drag symbol instances onto the artboard. Resize a symbol instance.
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With the symbol instance selected on the artboard, notice that, in the Control 
panel, you see the word “Symbol” and symbol-related options.

Next, you will edit the Rest Area symbol so that both instances are affected. There 
are several ways to edit a symbol, and in this section we will focus on one.

8	 With the Selection tool ( ), double-click the Rest Area symbol instance in the 
CENTRAL PARK area on the artboard.

A warning dialog box appears, stating that you are about to edit the original 
symbol and that all instances will update. Click OK to continue. This takes you 
into Symbol Editing mode, so you can’t edit any other objects on the page.

�	Tip: Another way to edit a symbol is to select the symbol instance on the artboard and then click 
the Edit Symbol button in the Control panel.

The Rest Area symbol instance you double-clicked appears to change in size. 
That’s because you are looking at the original symbol, not at the resized symbol 
instance on the page. You can now edit the shapes that make up the symbol.

9	 Select the Zoom tool ( ), and draw a marquee around the symbol instance in 
the CENTRAL PARK area to zoom in to it.

10	Select the Selection tool and click to select any of the red shapes that make up 
the picnic bench.

11	 In the Control panel, change the Fill color to the swatch named Local Green.

12	With the Selection tool, double-click away from the Rest Area content or click 
the Exit Symbol Editing Mode button ( ) in the upper-left corner of the artboard 
until you exit Symbol Editing mode so that you can edit the rest of the content.

C E N T R A LC E N T R A LC E N T R A L

13	Choose View > Fit Artboard In Window, and notice that both Rest Area 
instances on the artboard now have a green fill.

14	Choose File > Save, and leave the document open.
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Creating symbols
Illustrator also lets you create your own symbols. You can make symbols from 
objects, including paths, compound paths, text, raster images, mesh objects, and 
groups of objects. Symbols can even include active objects, such as brush strokes, 
blends, effects, or other symbol instances. Now, you will create your own symbol 
from existing artwork.

1	 Choose View > symbol content. This takes you to a zoomed in view off the right 
side of the artboard.

2	 With the Selection tool ( ), drag a marquee across the yellow fork content to 
select it. Drag the selected content into a blank area of the Symbols panel.

3	 In the Symbol Options dialog box, change the name to Food and select Graphic 
as the Type. Click OK to create the symbol.

In the Symbol Options dialog box, you will see a note that explains that there is 
no difference between a Movie Clip and a Graphic Type in Illustrator, so if you 
do not plan on exporting this content to Adobe Flash, you don’t need to worry 
about the Type.

� Note: If you are creating artwork for use on the web or for screen display, you can select  
Align To Pixel Grid in the Symbol Options dialog box to align the instances to the pixel grid. To learn 
more about the pixel grid, see Lesson 13, “Applying Appearance Attributes and Graphic Styles.”

After creating the Food symbol, the original fork group off the right edge of the 
artboard is converted to an instance of the Food symbol. You can leave it there or 
delete it, it’s up to you.

4	 If it isn’t already there, drag the Food symbol 
icon to the right of the Rest Area to change 
the order of the symbols in the panel.

Reordering symbols in the Symbols panel has 
no effect on the artwork. It can be a way to 
organize your symbols.

5	 Choose File > Save.

�	Note: You can only 
use placed art that is 
embedded (not linked)
to create a symbol.

�	Tip: By default, 
the selected artwork 
becomes an instance of 
the new symbol. If you 
don’t want the artwork 
to become an instance 
of the symbol, press the 
Shift key as you create 
the new symbol.
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Symbol Options
In the Symbol Options dialog box, you will encounter several options that are 
related to working with Adobe Flash. These options are briefly described below and 
will be addressed more fully later in this lesson.

•	 Select Movie Clip for type. Movie Clip is the default symbol type in Flash and 
in Illustrator.

•	 Specify a location on the Registration grid where you want to set the symbol’s 
anchor point. The location of the anchor point affects the position of the symbol 
within the screen coordinates.

•	 Select Enable Guides For 9-Slice Scaling if you want to utilize 9-Slice scaling 
in Flash.

—From Illustrator Help

Editing a symbol
In this next section, you will add several instances of the Food symbol to the 
artwork. Then, you will edit the symbol in the Symbols panel and all instances will 
be updated.

1	 Choose View > Fit Artboard In Window.

2	 Using the Selection tool ( ), drag an instance of the Food symbol (the yellow 
fork) from the Symbols panel to just to the right of the MARKET ST label in the 
middle of the artboard.
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3	 Drag another instance of the Food symbol from the Symbols panel just to the 
right of the EMERALD AVE label. See the figure for placement.
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Next, you will learn how to add more instances of a symbol that’s already on the 
artboard, using a modifier key.

4	 With the Selection tool ( ), press the Alt (Windows) or Option (Mac OS) key 
and drag one of the Food symbol instances already on the artboard to create a 
copy of the instance. Drag it to the right of the WALNUT ST label. When the 
new instance is in position, release the mouse button and then the modifier key.
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5	 Create four more copies by pressing the Alt (Windows) or Option (Mac OS) key 
and dragging one of the Food symbol instances. Drag them to the right of the 
EAST AVE, PARK AVE, COAST AVE, and FACTORY ST labels.
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You should now have a total of seven Food symbol instances on the artboard.

6	 In the Symbols panel, double-click the Food symbol to edit it. A temporary 
instance of the symbol appears in the center of the Document window.

Editing a symbol by double-clicking the symbol in the Symbols panel hides all 
artboard content except the symbol. This is just another way to edit a symbol.

7	 Press Ctrl++ (Windows) or Command++ (Mac OS) several times to zoom in.

8	 With the Direct Selection tool ( ), click to 
select the yellow shape. Change the Fill color 
to the swatch named New Local Blue in the  
Control panel.
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Since the fork content is grouped, selecting with the Direct Selection tool lets 
you select a shape within the group.

9	 Choose Select > All, or drag across the shapes with the Selection tool.

10	 Choose Object > Transform > Scale. In the Scale dialog box, change the Uniform 
Scale to 60% and then click OK.

This allows you to scale all of the symbol instances at once, rather than having 
to scale each individually. You could make other changes to the symbol artwork 
in a similar manner.

11	Double-click outside the symbol instance artwork on the artboard, or click the 
Exit Symbol Editing Mode button ( ) in the upper-left corner of the artboard to 
see all of the artwork.

12	Press Ctrl+0 (Windows) or Command+0 (Mac OS) to fit the artboard in  
the window.

13	With the Selection tool, drag the Food instances closer to the street labels.
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Change the fill color. Transform the content. The result.

As you saw earlier, when you double-click an instance of a symbol on the artboard, 
you edit it in place. By double-clicking a symbol in the Symbols panel, the rest 
of the artwork is hidden and the symbol appears in the center of the Document 
window. You can use whichever method suits your workflow.

14	Choose File > Save.

Replacing symbols
Next, you will create a symbol from some other shapes and then replace a few of 
the Food symbol instances with the new symbol.

1	 Choose View > symbol content.

2	 With the Selection tool ( ), select the green group of shapes with the smiley face 
(not the two trees).
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3	 Choose Object > Transform > Scale. In the Scale dialog box, change the Uniform 
Scale to 60%, if it’s not already 60, and then click OK.

4	 At the bottom of the Symbols panel, click the New Symbol button ( ). In the 
Symbol Options dialog box, change the name to Park and the Type to Graphic. 
Click OK.

5	 Choose View > Fit Artboard In Window.

6	 With the Selection tool, select the Food instance to the right of the PARK AVE 
label on the artboard. In the Control panel, click the arrow to the right of the 
Replace Instance With Symbol field to open a panel showing the symbols in the 
Symbols panel. Click the Park symbol in the panel.
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7	 Choose Select > Deselect.

8	 With the Selection tool, select the Food instance to the right of the COAST 
AVE label on the artboard. In the Control panel, click the arrow to the right of 
the Replace Instance With Symbol field to open a panel showing the symbols in 
the Symbols panel. Click the Park symbol in the panel.

9	 With the COAST AVE Park symbol instance still selected, choose Select >  
Same > Symbol Instance.

This is a great way to select all instances of a symbol in the document. Notice 
that it also selects the original symbol instance off the right side of the artboard.

10	Choose Object > Group, and then File > Save. Keep the file open.
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Symbol layers
When you edit a symbol using any of the methods 
described, open the Layers panel and you will see 
that the symbol has its own layering.

Similar to working with groups in Isolation mode, 
you see the layers associated with that symbol 
only, not the document’s layers. In the Layers 
panel, you can rename, add, delete, show/hide, 
and reorder content for a symbol.

Breaking a link to a symbol
At times, you will need to edit specific instances on the artboard but not all of 
them. Because you can only make changes to a symbol instance like scaling, 
opacity, flipping, and more, you may need to break the link between a symbol 
and an instance. This breaks the instance into the original objects or group, if the 
symbol content was originally grouped, on the artboard.

Next, you will break the link to one of the Food instances.

1	 With the Selection tool ( ) 
selected, click to select the 
Food symbol instance to 
the right of the EAST AVE 
label on the artboard. In the 
Control panel, click the  
Break Link button.

This object is now a series 
of paths, as indicated by the 
word “Path” on the left side of 
the Control panel. You should 
be able to see the anchor points of the shapes. This content will no longer 
update if the Food symbol is edited.

2	 Select the Zoom tool ( ), and drag a marquee across the selected content to 
zoom in.

3	 Choose Select > Deselect. Select the Direct Selection tool ( ), and then click the 
aqua shape.

4	 Change the Fill color to the swatch named Mid Gray in the Control panel.

5	 Choose Select > Deselect and then File > Save.

E A S T  A V E

B R O A D W A Y

�	Tip: You can also 
break the link to a 
symbol instance 
by selecting the 
symbol instance on 
the artboard and 
then clicking the 
Break Link To Symbol 
button ( ) at the 
bottom of the Symbols 
panel.
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Editing symbol options
Using the Symbols panel, you can easily rename or change other options for a 
symbol, which then updates all the symbol instances in the artwork. Next, you will 
rename the Rest Area symbol.

1	 Choose View > Fit Artboard In Window.

2	 In the Symbols panel, make sure that the Rest Area symbol is selected. Click the 
Symbol Options button ( ) at the bottom of the Symbols panel.

3	 In the Symbol Options dialog box, change the name to Picnic area and the 
Type to Graphic. Click OK.

Working with the Symbolism tools
The Symbol Sprayer tool ( ) in the Tools panel allows you to spray symbols on the 
artboard, creating symbol sets. A symbol set is a group of symbol instances that you 
create with the Symbol Sprayer tool. This can be really useful if, for instance, you 
were to create grass from individual blades of grass. Spraying the blades of grass 
speeds up this process greatly and makes it much easier to edit individual instances 
or the sprayed grass as a group. You can create mixed sets of symbol instances 
by using the Symbol Sprayer tool with one symbol and then using it again with 
another symbol.

Spraying symbol instances
Next, you will save several trees as a symbol and then use the Symbol Sprayer tool 
to apply those trees to your illustration.

1	 Choose View > symbol content.

2	 With the Selection tool ( ), drag across the two tree shapes to select them.

3	 Drag the trees group into the Symbols panel. In the Symbol Options dialog box, 
change the name to Trees and the Type to Graphic. Click OK.

4	 Choose Select > Deselect, and then choose View > Fit Artboard In Window.
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5	 Select the Symbol Sprayer tool ( ) in the Tools panel. Make sure the Trees 
symbol is selected in the Symbols panel.

6	 Double-click the Symbol Sprayer tool ( ) in the Tools panel. In the Symbolism 
Tools Options dialog box, change the Diameter to 1 in and the Intensity to 5, if 
they aren’t already, and change the Symbol Set Density to 7. Click OK.

�	Note: A higher intensity value increases the rate of change—the Symbol Sprayer tool sprays 
more and faster. The higher the symbol set density value, the more tightly packed the symbols are 
as you spray them. If you were to spray grass, for instance, you would want the intensity and density 
set high.

7	 Position the pointer over the CENTRAL PARK label, and click and drag from 
left to right and from right to left with the Symbol Sprayer, much like using an 
airbrush or a can of spray paint, to create trees in the park. Release the mouse 
button when you see some trees on the artboard, like in the figure.

Notice the bounding box around the Trees symbol instances, identifying it as a 
symbol set. As you spray, the instances are grouped together as a single object. 
If a symbol set is selected when you begin to spray with the Symbol Sprayer tool, 
the symbol instances that you are spraying are added to the selected symbol set. 
You can easily delete an entire symbol set by selecting it and then pressing the 
Delete key.

Spray the symbols. The result.

�	Tip: Make sure 
to keep moving the 
pointer. If you don’t 
like the results, you can 
choose Edit > Undo 
Spraying and try again.
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8	 Choose Select > Deselect.

9	 Position the Symbol Sprayer 
pointer over the trees you just 
created. Click and drag to add 
more trees.

Notice that after releasing 
the mouse button, you see 
a bounding box around 
only the new symbol set. To 
add symbol instances to an 
existing symbol set, you must first select  
the set.

10	With the new symbol set selected, press Delete or Backspace to delete it.

11	With the Selection tool, click to select the first Trees symbol set you created.

12	Select the Symbol Sprayer 
tool, and add more trees 
to the first symbol set. Try 
clicking and releasing, instead 
of clicking and dragging, to 
add one tree at a time.

13	Choose File > Save, and leave 
the symbol set selected.

Editing symbols with the Symbolism tools
Besides the Symbol Sprayer tool, there is a series of Symbolism tools that allow you 
to edit the size, color, rotation, and more of the instances within a symbol set. In 
the next steps, you will edit the trees in the Trees symbol set using the Symbolism 
tools in the Tools panel.

1	 With the Trees symbol set and the Symbol Sprayer tool ( ) still selected, 
position the pointer over one of the tree instances. Press the Alt (Windows) or 
Option (Mac OS) key, and click to delete one of the instances in the set.

2	 Select the Symbol Sizer tool ( ) from the Symbol Sprayer tool ( ) group in 
the Tools panel. Double-click the Symbol Sizer tool, and change the Intensity  
to 3 in the Symbolism Tools Options dialog box. Click OK.

3	 Position the pointer over some of the trees, and click the mouse button to 
increase the size of some of the trees. In another area of trees, press the Alt 
(Windows) or Option (Mac OS) key while you are using the Symbol Sizer tool 
to reduce the size of the selected symbol set. Make some of the trees smaller 
than the rest, varying the sizes.

�	Tip: If you don’t 
like the placement of 
a tree, you can choose 
Edit > Undo Spraying to 
remove the instances 
you sprayed in the 
previous click.

�	Tip: If the Symbol 
Sizer tool is sizing too 
quickly, double-click 
the Symbol Sizer tool in 
the Tools panel and try 
lowering the Intensity 
and Density values in 
the Symbolism Tools 
Options dialog box.
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Resize some of the trees. The result.

Now, you will reposition some of the trees in the symbol set.

4	 Select the Symbol Shifter tool ( ) from the Symbol Sizer tool group. Double-
click the Symbol Shifter tool. In the Symbolism Tools Options dialog box, 
change the Intensity to 8, and then click OK.

The higher the Intensity, the further you can move the symbol instances.

5	 Position the pointer over a tree in the selected symbol set, and then drag left or 
right to move it. Drag the trees away from the CENTRAL PARK label so that 
you can see the whole thing.

The more you move the pointer, the further you can drag instances. The trees 
you see in your symbol set may be arranged differently than in the figures and 
that’s okay.

Drag the trees. The result.

You may notice that, as you drag, some of the trees that 
should be behind other trees are actually on top of them.

Next, you will fix this with the Symbol Shifter tool.

�	Tip: The circle 
(diameter setting) 
around the Symbolism 
tools pointers indicates 
that any symbol 
instances within that 
circle will be affected. 
Press the left bracket 
key ([) or right bracket 
key (]) to change the 
brush diameter.
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You may want to zoom in to the symbol set for the next steps.

6	 With the Symbol Shifter tool selected, press the left bracket key ([) a few times 
to decrease the diameter. Make sure that the circle surrounding the pointer 
(that indicates the diameter) isn’t much bigger than a tree. Shift-click one of the 
trees that should be in front to bring it to the front.

7	 Select the Symbol Stainer  
tool ( ) from the Symbol 
Shifter tool group in the Tools 
panel. With the symbol set 
still selected, position the 
pointer over the symbol set. 
Press the right bracket key (]) 
several times to increase the 
size of the brush.

8	 Change the Fill color in the Control panel to New Local Yellow, and begin 
clicking on trees in the symbol set to change their color.

You can always choose Edit > Undo Staining, if you don’t like how it’s affecting 
the trees, or Alt-click (Windows) or Option-click (Mac OS) to decrease the 
amount of colorization.

�	Tip: There are lots of Symbolism tools for you to experiment with, including the Symbol Styler 
tool ( ), which allows you to apply graphic styles to symbol instances in the symbol set. To learn 
more about the different types of Symbolism tools available, search for “symbolism tool gallery” in 
Illustrator Help (Help > Illustrator Help).

9	 Choose Select > Deselect, and then choose File > Save.

Copying and editing symbol sets
A symbol set is treated as a single object. In order to edit the instances in it, you use 
the Symbolism tools in the Tools panel, as you’ve already seen. You can, however, 
duplicate symbol instances and use the Symbolism tools to make the duplicates 
look different.

�	Tip: Shift+Alt-click 
(Windows) or Shift+ 
Option-click (Mac OS) to 
send a tree behind.

�	Tip: The longer you 
press the mouse button, 
the more stained  
they become. Try 
quickly tapping the 
mouse button.

Change the stacking order of instances. The final result.
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Next, you will duplicate the Trees symbol set.

1	 Select the Selection tool ( ), and click to select the Trees symbol set.

2	 Press the Alt (Windows) or Option (Mac OS) key, and drag a copy of the 
instances down and to the left, into the lower-left part of the CENTRAL PARK 
green area. When it is in position (see the figure), release the mouse button and 
then the modifier key.

� Note: There are many transformations that you can make to a symbol set. You can also drag a 
point in the bounding box of a symbol set with the Selection tool to resize it.

3	 Select the Symbol Shifter 
tool ( ) from the Symbol 
Stainer tool group. Double-
click the Symbol Shifter tool, 
and change the Intensity to 9. 
Click OK. Drag the trees in 
the symbol set so that they fit 
within the green park area, as 
you see in the figure.

You can change the diameter by pressing the left bracket ([) key or right bracket 
(]) key. This will help you move more or fewer trees.

4	 With the Symbol shifter tool, 
Shift-click the trees that 
should be in front, to bring 
them to the front. Shift+Alt-
click (Windows) or Shift+ 
Option-click (Mac OS) to 
send a tree behind.

5	 Choose Select > Deselect.

6	 Choose File > Save.
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Storing and retrieving artwork 
in the Symbols panel
Saving frequently used logos or other artwork as symbols lets you access 
them quickly. Unfortunately, symbols you create in one document are not 
accessible by default in another document. In this next part of the lesson, you will 
take symbols that you’ve created and save them as a new symbol library that you 
can share with other documents or users.

1	 In the Symbols panel, click the Symbol 
Libraries Menu button ( ) at the bottom and 
then choose Save Symbols.

�	Note: When saving symbols as a separate library, the 
document that contains the symbols that you want to save 
should be open and active in the Document window.

2	 In the Save Symbols As Library dialog box, 
choose a location, such as your Desktop, to 
place the symbol library file. Name the library 
file map_symbols.ai. Click Save.

�	Note: When you first open the Save Symbols As Library dialog box, Illustrator takes you to the 
default Symbols folder, where you can store the libraries that you create. Illustrator recognizes any 
libraries stored here and lets you choose them from the Symbol Libraries menu later.

�	Tip: If you save the library in the default folder, you can make subfolders and create a folder 
structure that suits you. You can then easily access them using the Symbol Libraries Menu button or 
by choosing Window > Symbol Libraries > User Defined > your symbol library.

3	 Without closing the map.ai file, create a new document by choosing 
File > New. Leave the default settings, and then click OK.

4	 In the Symbols panel, click the Symbol Libraries Menu button ( ) and choose 
Other Library at the bottom of the menu. Navigate to the folder where you 
saved the map_symbols.ai library, select it, and then click Open.

The map_symbols library appears as a free-floating panel in the workspace. You 
can dock it or leave it where it is. It stays open as long as Illustrator is open. 
When you close Illustrator, and then relaunch it, this panel does not reopen.

5	 Drag any of the Symbols from the map_symbols library panel onto the artboard.

6	 Choose File > Close, and do not save the new file.

7	 Close the map_symbols library.

8	 With the map.ai file open, choose File > Save, if necessary, and then File > Close.

�	Note: Symbol 
libraries are saved as 
Adobe Illustrator  
(.ai) files.
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Mapping a symbol to 3D artwork
You can apply 2D artwork stored as a symbol in the Symbols panel to selected 
surfaces on a 3D object. To learn about mapping symbols to 3D artwork, see 
Lesson 12, “Applying Effects.”

Working with symbols and Flash integration
Illustrator also provides excellent support for SWF and SVG file type export. When 
you export to Flash, you can set the symbol type to Movie Clip. In Adobe Flash, 
you can choose another type, if necessary. You can also specify 9-slice scaling in 
Illustrator so that the movie clips scale appropriately when used for user  
interface components.

You can move Illustrator artwork into the Flash editing environment or directly 
into the Flash Player. You can copy and paste artwork, save files as SWF, or 
export artwork directly to Flash. In addition, Illustrator provides support for Flash 
dynamic text and movie clip symbols.

The following is a generic symbol workflow in Illustrator:

•	 Step 1: Symbol creation
When you create a symbol in Illustrator, the Symbol Options dialog box lets 
you name the symbol and set the following options, specific to Flash: Movie 
Clip symbol type (which is the default for Flash symbols), Flash registration 
grid location, and 9-slice scaling guides. In addition, you can use many of the 
same symbol keyboard shortcuts in Illustrator and Flash, such as pressing F8 
to create a symbol.

•	 Step 2: Isolation mode for symbol editing
•	 Step 3: Symbol properties and links
•	 Step 4: Static, dynamic, and input text objects

Next, you will create a button, save it as a symbol, and then edit the symbol options.

1	 Choose Window > Workspace > Reset Essentials.

2	 Choose File > New.

3	 In the New Document dialog box, choose Web from the New Document Profile 
menu. Keep the rest of the options at their default settings, and then click OK.

4	 Choose File > Save As. In the Save As dialog box, name the file buttons.ai and 
navigate to the Lesson14 folder. Leave the Save As Type option set to Adobe 
Illustrator (*.AI) (Windows) or the Format option set to Adobe Illustrator (ai) 
(Mac OS), and then click Save. In the Illustrator Options dialog box, leave the 
Illustrator options at their default settings and then click OK.

5	 Choose Window > Symbol Libraries > Web Buttons And Bars.

� Note: If you don’t 
see “Reset Essentials” in 
the Workspace menu, 
choose Window > 
Workspace > Essentials 
before choosing 
Window > Workspace > 
Reset Essentials.
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6	 Choose Small List View from the Symbols panel menu ( ).

7	 Drag the blue Bullet 4 - Forward symbol from the Web Buttons And Bars panel 
onto the artboard. Close the Web Buttons And Bars panel menu group.

8	 With the Selection tool ( ), Shift-click the upper-right corner of the button and 
drag to make it roughly twice its original size, releasing the mouse button and 
then the key.

9	 With the button still selected, change the Instance Name in the Control panel to 
Home and press Enter or Return.

The Instance Name is optional when working in Illustrator and is used to 
identify one symbol instance from another. Entering an instance name for each 
button is useful if you choose to import the Illustrator content to the stage in 
Flash (File > Import > Import To Stage).

10	With the button selected, begin dragging it to the right. As you drag, press 
Shift+Alt (Windows) or Shift+Option (Mac OS) to create a copy. Release the 
mouse button first and then the modifier keys.

11	 In the Control panel, change the Instance Name to Info and press Enter or Return.

12	With one of the buttons still selected, click the 
Symbols panel icon ( ) to open the panel. Click 
the Symbol Options button ( ) at the bottom of 
the panel. Make sure that Movie Clip is chosen 
from the Type menu, select Enable Guides For 
9-Slice Scaling, and then click OK.

Next, you’ll adjust the 9-slice scaling guides.

13	With the Selection tool, double-click the 
leftmost button to enter Isolation mode. When 
the warning dialog box appears, click OK.

14	Select the Zoom tool ( ) in the Tools panel, and click three times on the 
leftmost button to zoom in. Choose Select > All.

Choosing Select > All allows you to see the anchor points in the shapes. When 
you adjust the 9-slice scaling guides, you want to try to position them to 
indicate the scalable part of the object (usually not the corners).

Resize the symbol instance. Name the instance. Duplicate the instance.
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15	With the Selection tool, drag the rightmost dotted 
line to the right so that it lines up approximately with 
the anchor points (circled), as shown in the figure.

You can use 9-slice scaling (scale-9) to specify 
component-style scaling for graphic style and movie 
clip symbols. To maintain the visual integrity of the 
symbol, corners are not scaled, while the remaining 
areas of the image are scaled (as opposed to being stretched) larger or smaller, 
as needed.

16	With the Selection tool, double-click away from the buttons to exit  
Isolation mode.

17	Choose View > Fit Artboard In Window and then File > Save.

Understanding symbol  
options for Flash
Movie Clip: Use movie clip symbols to create 
reusable pieces of animation (in Flash). Movie 
clips have their own multiframe Timeline that is 
independent from the main Timeline—think of 
them as nested inside a main Timeline that can 
contain interactive controls, sounds, and even 
other movie clip instances. You can also place 
movie clip instances inside the Timeline of a button 
symbol to create animated buttons. In addition, 
movie clips are scriptable with ActionScript®.

Align to Pixel Grid: To create a pixel-aligned 
symbol, select the Align to Pixel Grid option from the Symbol Options dialog box. 
Symbols aligned to the pixel grid remain aligned to the pixel grid at all locations of 
the artboard, in their actual size.

9-slice scaling: You can use 9-slice scaling (scale-9) to specify component-style 
scaling for graphic style and movie clip symbols. This type of scaling lets you create 
movie clip symbols that scale appropriately for use as user interface components, as 
opposed to the type of scaling typically applied to graphics and design elements.

The symbol is conceptually divided into nine sections with a grid-like overlay, and 
each of the nine areas is scaled independently. To maintain the visual integrity 
of the symbol, corners are not scaled, while the remaining areas of the image are 
scaled (as opposed to being stretched) larger or smaller, as needed.

—From Illustrator Help

For the next section, you need to have Adobe Flash CS6 installed on your machine.

�	Note:  If you don’t 
own Adobe Flash 
CS6, you can install a 
free trial version from 
Adobe.com for 30 
days, here: http://www.
adobe.com/downloads/

http://www.adobe.com/downloads/
http://www.adobe.com/downloads/
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1	 Open Adobe Flash CS6.

2	 Choose File > New. In the New Document dialog box, make sure that the 
General tab is selected and that ActionScript 3.0 is also selected as the Type. 
Click OK.

3	 Choose File > Import > Import To Library in Adobe Flash. Navigate to the 
buttons.ai file you just saved in Illustrator, and then click Open. The Import 
“buttons.ai” To Library dialog box appears.

In this dialog box, you can select which artboard to import, which layers to 
import, how to import the content, and more. The Import Unused Symbols 
option at the bottom of the dialog box brings all the symbols in the Illustrator 
Symbols panel into the Flash Library panel. This can be very useful if, for 
instance, you are developing a series of buttons for a site but they are not on the 
artboard in Illustrator.

4	 Click OK.

5	 Open the Library panel by clicking the 
Library panel tab on the right side of the 
workspace. Click the arrow to the left of 
the folder names to reveal the assets as 
well as the Bullet 4 - Forward symbol in 
the Illustrator Symbols folder.

6	 Drag the Bullet 4 - Forward symbol onto  
the stage.

7	 Choose File > Close to close the Flash file, 
and don’t save changes. Close Flash, and 
return to Illustrator. Close all open files 
in Illustrator.




